summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMārtiņš Možeiko2022-11-06 11:58:23 -0800
committerMārtiņš Možeiko2022-11-06 11:58:23 -0800
commit2b76b4df2456dd385ae2d906aa302a5498aa2a3c (patch)
treeb20b04ac4ebd679a5541cf98b35db6704f2bfd2d
parent0aa07ef3327060f6b092abd570a4c362bb987a34 (diff)
downloadaur-2b76b4df2456dd385ae2d906aa302a5498aa2a3c.tar.gz
version 1.20
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD32
2 files changed, 19 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e8f56821e781..19c9812c26ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = opencl-caps-viewer
pkgdesc = OpenCL Hardware Capability Viewer
- pkgver = 1.0
+ pkgver = 1.20
pkgrel = 1
url = https://opencl.gpuinfo.org/
arch = x86_64
license = GPL2
depends = opencl-icd-loader
- depends = qt5-base
- source = opencl-caps-viewer::git+https://github.com/SaschaWillems/OpenCLCapsViewer.git#tag=1.00
+ depends = qt5-x11extras
+ source = git+https://github.com/SaschaWillems/OpenCLCapsViewer.git#tag=1.20
source = git+https://github.com/KhronosGroup/OpenCL-Headers.git
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 0d74e2726fd2..6c6db4025af6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,40 @@
# Maintainer: Martins Mozeiko <martins.mozeiko@gmail.com>
pkgname=opencl-caps-viewer
-pkgver=1.0
-_pkgtag=1.00
+pkgver=1.20
pkgrel=1
pkgdesc="OpenCL Hardware Capability Viewer"
arch=("x86_64")
-depends=("opencl-icd-loader" "qt5-base")
+depends=("opencl-icd-loader" "qt5-x11extras")
url="https://opencl.gpuinfo.org/"
license=("GPL2")
-source=("opencl-caps-viewer::git+https://github.com/SaschaWillems/OpenCLCapsViewer.git#tag=${_pkgtag}"
+source=("git+https://github.com/SaschaWillems/OpenCLCapsViewer.git#tag=${pkgver}"
"git+https://github.com/KhronosGroup/OpenCL-Headers.git")
sha256sums=("SKIP"
"SKIP")
prepare() {
- cd "$srcdir/${pkgname}"
+ cd "$srcdir/OpenCLCapsViewer"
git submodule init
git config submodule.OpenCL-Headers.url "$srcdir/OpenCL-Headers"
- git submodule update
+ git -c protocol.file.allow=always submodule update
+
+ # Correct binary install path
+ sed -i 's|target.path = /opt/$${TARGET}/bin|target.path = /usr/bin|g' OpenCLCapsViewer.pro
}
build() {
- cd "$srcdir/${pkgname}"
- qmake
+ cd "$srcdir/OpenCLCapsViewer"
+ qmake-qt5 OpenCLCapsViewer.pro \
+ DEFINES+=X11 \
+ CONFIG+=release \
+ PREFIX=/usr
make
}
package() {
- install -dm755 "$pkgdir"/usr/bin
- install -m755 "${srcdir}/${pkgname}"/OpenCLCapsViewer "${pkgdir}"/usr/bin/OpenCLCapsViewer
-
- install -dm755 "$pkgdir"/usr/share/applications
- install -m644 "${srcdir}/${pkgname}"/OpenCLCapsViewer.desktop "${pkgdir}"/usr/share/applications/OpenCLCapsViewer.desktop
-
- install -dm755 "${pkgdir}"/usr/share/icons
- install -m644 "${srcdir}/${pkgname}"/Resources/icon.png "${pkgdir}"/usr/share/icons/openclCapsViewer.png
+ cd "$srcdir/OpenCLCapsViewer"
+ make INSTALL_ROOT="$pkgdir/" install
+ install -m644 Resources/icon.png "${pkgdir}"/usr/share/icons/hicolor/256x256/apps/openclCapsViewer.png
}