summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Holthuis2017-08-25 15:19:10 +0200
committerJan Holthuis2017-08-25 15:19:10 +0200
commit32b1c86b1882e92650e2b3675d51e4e0ab7a5df8 (patch)
tree7434ab96c64644180c61110274e3cb318be96568
downloadaur-32b1c86b1882e92650e2b3675d51e4e0ab7a5df8.tar.gz
Add release version 0.0
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD48
-rw-r--r--openclaw.install3
3 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..664643868bd0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by mksrcinfo v8
+# Fri Aug 25 13:18:33 UTC 2017
+pkgbase = openclaw
+ pkgdesc = Reimplementation of Captain Claw (1997) platformer
+ pkgver = 0.0
+ pkgrel = 1
+ url = https://github.com/pjasicek/OpenClaw
+ install = openclaw.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = unknown
+ depends = sdl2
+ depends = sdl2_gfx
+ depends = sdl2_image
+ depends = sdl2_mixer
+ depends = sdl2_ttf
+ depends = tinyxml
+ optdepends = mono: launcher support
+ optdepends = timidity++: background music support
+ optdepends = timidity-freepats: background music support
+ source = https://github.com/pjasicek/OpenClaw/archive/v0.0.tar.gz
+ source = https://github.com/pjasicek/OpenClaw/releases/download/v0.0/openclaw-1.0-1.x86_64.rpm
+ sha256sums = (d53d6e9054452cf465ed485094d3645f58866249bbeb59cf38262352d639e76b 99095cc136e35701016bc5f70bcb8b0cb20538fc0a778cdccd38c4275ca85441)#
+
+pkgname = openclaw
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..07b25279ff50
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Jan Holthuis <holthuis dot jan at googlemail dot com>
+pkgname=openclaw
+_gitname=OpenClaw
+pkgver=0.0
+pkgrel=1
+pkgdesc="Reimplementation of Captain Claw (1997) platformer"
+arch=('i686' 'x86_64')
+url='https://github.com/pjasicek/OpenClaw'
+license=('GPL' 'unknown')
+depends=('sdl2' 'sdl2_gfx' 'sdl2_image' 'sdl2_mixer' 'sdl2_ttf' 'tinyxml')
+optdepends=(
+ 'mono: launcher support'
+ 'timidity++: background music support'
+ 'timidity-freepats: background music support'
+)
+source=(
+ "https://github.com/pjasicek/${_gitname}/archive/v${pkgver}.tar.gz"
+ "https://github.com/pjasicek/${_gitname}/releases/download/v${pkgver}/openclaw-1.0-1.x86_64.rpm"
+)
+sha256sums=('d53d6e9054452cf465ed485094d3645f58866249bbeb59cf38262352d639e76b'
+ '99095cc136e35701016bc5f70bcb8b0cb20538fc0a778cdccd38c4275ca85441')#
+install='openclaw.install'
+
+build() {
+ mkdir -p "${srcdir}/${_gitname}-$pkgver/build"
+ cd "${srcdir}/${_gitname}-$pkgver/build"
+ cmake ..
+ make
+}
+
+package() {
+ cd "${srcdir}/${_gitname}-$pkgver/Build_Release"
+
+ # Binaries
+ install -Dm644 'ClawLauncher.exe' "${pkgdir}/usr/bin/ClawLauncher.exe"
+ install -Dm755 'clawlauncher' "${pkgdir}/usr/bin/clawlauncher"
+ install -Dm755 'openclaw' "${pkgdir}/usr/bin/openclaw"
+
+ # Recreated Assets
+ install -Dm644 'ASSETS.ZIP' "${pkgdir}/usr/share/openclaw/ASSETS.ZIP"
+ install -Dm644 'clacon.ttf' "${pkgdir}/usr/share/openclaw/clacon.ttf"
+ install -Dm644 'console02.tga' "${pkgdir}/usr/share/openclaw/console02.tga"
+ install -Dm644 'SAVES.XML' "${pkgdir}/usr/share/openclaw/SAVES.XML"
+ install -Dm644 'config_linux_release.xml' "${pkgdir}/usr/share/openclaw/config.xml"
+
+ # Original Game Assets (from the rpm file)
+ install -Dm644 "${srcdir}/usr/share/openclaw/CLAW.REZ" "${pkgdir}/usr/share/openclaw/CLAW.REZ"
+}
diff --git a/openclaw.install b/openclaw.install
new file mode 100644
index 000000000000..dd3ed96f8ed3
--- /dev/null
+++ b/openclaw.install
@@ -0,0 +1,3 @@
+post_install() {
+ echo "You need to copy both 'config.xml' and 'SAVES.XML' from /usr/share/openclaw/ to ~/.config/openclaw/ before you can run the game!"
+}