summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenedict Etzel2016-01-17 20:50:16 +0100
committerBenedict Etzel2016-01-17 20:50:16 +0100
commit64c064eb44c2349a3642e48b28e2fd070b656192 (patch)
tree1fd9e489e79044bfec638cc877bd7ab85d6d57a5
parent39f3e4b755fb3b2d301481fa5bdae6b661b796a2 (diff)
downloadaur-64c064eb44c2349a3642e48b28e2fd070b656192.tar.gz
Update to version 7.0
-rw-r--r--PKGBUILD4
-rw-r--r--directories.patch15
2 files changed, 10 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1c58f2646924..a6d3600cf61d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Wesley <rudirennsau at hotmail dot com>
pkgname=openclonk
-pkgver=6.1
+pkgver=7.0
pkgrel=1
_orig=$pkgname-$pkgver-src
pkgdesc='Multiplayer-action-tactic-skill game'
@@ -16,7 +16,7 @@ makedepends=('cmake' 'boost' 'imagemagick' 'mesa')
conflicts=('clonk_rage')
install=$pkgname.install
source=("http://openclonk.org/builds/release/$pkgver/$pkgname-$pkgver-src.tar.bz2" 'directories.patch')
-md5sums=('4d2b93bc4e0e5e97ee35b890838316b8'
+md5sums=('96303965e696ac284f054ce58ee51fa9'
'55e35baf307d699a704e9d939d8402fb')
prepare() {
diff --git a/directories.patch b/directories.patch
index 5eac963dfb05..85af03ad00af 100644
--- a/directories.patch
+++ b/directories.patch
@@ -1,15 +1,16 @@
---- openclonk-release-6.0-src/CMakeLists.txt 2015-03-12 22:21:51.000000000 +0100
-+++ openclonk-release-6.0-src.new/CMakeLists.txt 2015-03-15 20:57:35.333928593 +0100
-@@ -1215,7 +1215,7 @@
+diff -aur a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt 2016-01-15 21:56:57.000000000 +0100
++++ b/CMakeLists.txt 2016-01-17 20:48:52.194153030 +0100
+@@ -100,7 +100,7 @@
# Don't put this into CMAKE_CXX_FLAGS because otherwise it is cached,
# and when the path is changed both the old and new definition appears
# in the list of flags.
- add_definitions("-DOC_SYSTEM_DATA_DIR=\"${CMAKE_INSTALL_PREFIX}/share/games/openclonk\"")
+ add_definitions("-DOC_SYSTEM_DATA_DIR=\"${CMAKE_INSTALL_PREFIX}/share/openclonk\"")
endif()
- if(OC_CXX_FLAGS)
- list(REMOVE_DUPLICATES OC_CXX_FLAGS)
-@@ -1537,7 +1537,7 @@
+
+ if(APPLE)
+@@ -1461,7 +1461,7 @@
DEPENDS "${native_c4group}"
VERBATIM
)
@@ -18,7 +19,7 @@
endif()
endforeach()
-@@ -1551,7 +1551,7 @@
+@@ -1475,7 +1475,7 @@
install(CODE "execute_process(COMMAND update-desktop-database)")
# Install binaries