summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederic Bezies2021-03-20 15:31:41 +0100
committerFrederic Bezies2021-03-20 15:31:41 +0100
commit9141ae101b53cc4693439fd720a769f6aa8d851d (patch)
treeff44307812646aa443a0e1f0e635c0107ea53f21
parente350116ccda6843d4d9af8ae8f01691129294352 (diff)
downloadaur-9141ae101b53cc4693439fd720a769f6aa8d851d.tar.gz
adopted and updated PKGBUILD
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
-rw-r--r--directories.patch97
-rw-r--r--openclonk.install16
4 files changed, 10 insertions, 130 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9bec7b6af296..a30ec1663fad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = openclonk-git
pkgdesc = Multiplayer-action-tactic-skill game
- pkgver = r11397.c13bc33d7
+ pkgver = r11491.701bcf38c
pkgrel = 1
url = http://openclonk.org
- install = openclonk.install
arch = i686
arch = x86_64
license = custom
@@ -11,21 +10,20 @@ pkgbase = openclonk-git
makedepends = boost
makedepends = mesa
makedepends = git
- depends = glew
depends = freealut
depends = miniupnpc
- depends = libxrandr
depends = sdl2
- depends = sdl_mixer>=1.2
- depends = desktop-file-utils
depends = qt5-base
depends = hicolor-icon-theme
+ depends = tinyxml
+ depends = libepoxy
+ depends = libvorbis
provides = openclonk
conflicts = clonk_rage
conflicts = openclonk
conflicts = openclonk-music
source = openclonk-git::git+https://github.com/openclonk/openclonk#branch=master
- md5sums = SKIP
+ sha256sums = SKIP
pkgname = openclonk-git
diff --git a/PKGBUILD b/PKGBUILD
index 0693f4b2b00a..e478b4ab6e0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: George Tokmaji <tokmajigeorge@gmail.com>
+# Maintainer: Frederic Bezies <fredbezies at gmail dot com>
+# Contributor: George Tokmaji <tokmajigeorge@gmail.com>
# Contributor: Benedict Etzel <developer@beheh.de>
# Contributor: Jonathan Steel <mail at jsteel dot org>
# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
@@ -7,29 +8,23 @@
pkgname=openclonk-git
pkgrel=1
-pkgver=r11397.c13bc33d7
+pkgver=r11491.701bcf38c
pkgdesc='Multiplayer-action-tactic-skill game'
arch=('i686' 'x86_64')
url='http://openclonk.org'
license=('custom')
-depends=('glew' 'freealut' 'miniupnpc' 'libxrandr' 'sdl2' 'sdl_mixer>=1.2' 'desktop-file-utils' 'qt5-base' 'hicolor-icon-theme')
-install=openclonk.install
+depends=('freealut' 'miniupnpc' 'sdl2' 'qt5-base' 'hicolor-icon-theme' 'tinyxml' 'libepoxy' 'libvorbis')
makedepends=('cmake' 'boost' 'mesa' 'git')
provides=('openclonk')
conflicts=('clonk_rage' 'openclonk' 'openclonk-music')
source=("$pkgname::git+https://github.com/openclonk/openclonk#branch=master")
-md5sums=('SKIP')
+sha256sums=('SKIP')
pkgver() {
cd "$pkgname"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd ${pkgname}
- patch -p1 -i "$srcdir"/../directories.patch
-}
-
build() {
cd ${pkgname}
diff --git a/directories.patch b/directories.patch
deleted file mode 100644
index c56f8f8aba9c..000000000000
--- a/directories.patch
+++ /dev/null
@@ -1,97 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 3aef3ba1c..051afed10 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -75,7 +75,6 @@ CMAKE_DEPENDENT_OPTION(USE_COCOA "Use Apple Cocoa widgets." ON "APPLE" O
- CMAKE_DEPENDENT_OPTION(USE_WIN32_WINDOWS "Use Microsoft Desktop App User Interface widgets." ON "WIN32" OFF)
- CMAKE_DEPENDENT_OPTION(USE_SDL_MAINLOOP "Use SDL to create windows etc. Qt editor." ON "NOT USE_COCOA AND NOT USE_WIN32_WINDOWS AND NOT HEADLESS_ONLY" OFF)
- option(WITH_AUTOMATIC_UPDATE "Automatic updates are downloaded from the project website." OFF)
--CMAKE_DEPENDENT_OPTION(WITH_APPDIR_INSTALLATION "Install into an AppDir" OFF "UNIX AND NOT APPLE AND WITH_AUTOMATIC_UPDATE" ON)
- option(HEADLESS_ONLY "Only build headless parts. Somewhat reduces dependencies. (still needs libpng because that one's small and hard to remove.) Only tested with make/gcc/linux." OFF)
- option(C4GROUP_TOOL_ONLY "Only build c4group binary." OFF)
-
-@@ -156,6 +155,10 @@ if(WIN32 AND MINGW)
- set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -Wl,--nxcompat -Wl,--dynamicbase")
- endif()
-
-+if(UNIX)
-+ add_definitions("-DOC_SYSTEM_DATA_DIR=\"${CMAKE_INSTALL_PREFIX}/share/games/openclonk\"")
-+endif()
-+
- if(APPLE)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fobjc-arc -headerpad_max_install_names")
- endif()
-@@ -1435,11 +1438,7 @@ endif()
- # Don't allow installation for WITH_AUTOMATIC_UPDATE because otherwise
- # the installed binary wouldn't find its game data in the system data path.
- IF(WITH_AUTOMATIC_UPDATE)
-- if(WITH_APPDIR_INSTALLATION)
-- INSTALL(CODE "MESSAGE(\"WITH_APPDIR_INSTALLATION is enabled, installation will create an AppDir\")")
-- else()
-- INSTALL(CODE "MESSAGE(SEND_ERROR \"Installation is only supported for WITH_AUTOMATIC_UPDATE disabled\")")
-- endif()
-+ INSTALL(CODE "MESSAGE(SEND_ERROR \"Installation is only supported for WITH_AUTOMATIC_UPDATE disabled\")")
- ENDIF()
-
- if(NOT C4GROUP_TOOL_ONLY)
-@@ -1583,12 +1582,7 @@ if(NOT HEADLESS_ONLY AND NOT C4GROUP_TOOL_ONLY)
- install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/openclonk.appdata.xml DESTINATION share/appdata)
-
- # Install binaries
-- if(WITH_APPDIR_INSTALLATION)
-- # AppDir expects binaries in /usr/bin
-- install(TARGETS openclonk DESTINATION bin)
-- else()
-- install(TARGETS openclonk DESTINATION games)
-- endif()
-+ install(TARGETS openclonk DESTINATION games)
- else()
- install(TARGETS openclonk
- BUNDLE DESTINATION .
-diff --git a/config.h.cmake b/config.h.cmake
-index e2cec4c69..5279d2930 100644
---- a/config.h.cmake
-+++ b/config.h.cmake
-@@ -90,13 +90,12 @@
-
- /* Enable automatic update system */
- #cmakedefine WITH_AUTOMATIC_UPDATE 1
--#cmakedefine WITH_APPDIR_INSTALLATION 1
-
- /* Select an audio provider */
- #define AUDIO_TK AUDIO_TK_${Audio_TK_UPPER}
- #else
- #define AUDIO_TK AUDIO_TK_NONE
--#endif // USE_CONSOLE
-+#endif
-
- #define AUDIO_TK_NONE 0
- #define AUDIO_TK_OPENAL 1
-@@ -105,12 +104,5 @@
- /* Include OpenAL extensions (alext.h) for sound modifiers */
- #cmakedefine HAVE_ALEXT 1
-
--/* Path to data directory */
--#ifdef WITH_APPDIR_INSTALLATION
--#define OC_SYSTEM_DATA_DIR "../share/games/openclonk"
--#else
--#define OC_SYSTEM_DATA_DIR "${CMAKE_INSTALL_PREFIX}/share/games/openclonk"
--#endif
--
- /* Path to /proc/self/exe (Linux) or equivalent */
- #cmakedefine PROC_SELF_EXE "${PROC_SELF_EXE}"
-diff --git a/src/config/C4Config.cpp b/src/config/C4Config.cpp
-index 50bc001bd..d310c38ce 100644
---- a/src/config/C4Config.cpp
-+++ b/src/config/C4Config.cpp
-@@ -476,10 +476,6 @@ void C4ConfigGeneral::DeterminePaths()
- SCopy(ExePath.getMData(),SystemDataPath);
- #elif defined(__APPLE__)
- SCopy(::Application.GetGameDataPath().c_str(),SystemDataPath);
--#elif defined(WITH_AUTOMATIC_UPDATE) && defined(WITH_APPDIR_INSTALLATION)
-- // AppDir: layout like normal unix installation, but relative to executable.
-- auto str = FormatString("%s%s", ExePath.getMData(), OC_SYSTEM_DATA_DIR);
-- SCopy(str.getMData(), SystemDataPath);
- #elif defined(WITH_AUTOMATIC_UPDATE)
- // WITH_AUTOMATIC_UPDATE builds are our tarball releases and
- // development snapshots, i.e. where the game data is at the
diff --git a/openclonk.install b/openclonk.install
deleted file mode 100644
index e3f207c342e4..000000000000
--- a/openclonk.install
+++ /dev/null
@@ -1,16 +0,0 @@
-post_install() {
- gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor > /dev/null 2>&1
- update-desktop-database > /dev/null 2>&1
-}
-
-post_upgrade() {
- post_install $1
-}
-
-pre_remove() {
- update-desktop-database > /dev/null 2>&1
-}
-
-post_remove() {
- post_install $1
-}