summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbanana-bred2024-01-30 20:16:55 -0500
committerbanana-bred2024-01-30 20:16:55 -0500
commit24e0835d6aa8391465b8cf9eab1fe3204e9a5e17 (patch)
tree44aad84535fbc7d086ea2846d8ec3df3f34a48db
parente9b535e184b07c8e130772e3433235e7ad11bf90 (diff)
downloadaur-24e0835d6aa8391465b8cf9eab1fe3204e9a5e17.tar.gz
version 2.10.1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD66
2 files changed, 47 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 51bd91afb993..dc1b59ae330b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,15 @@
pkgbase = opencoarrays
pkgdesc = A transport layer for coarray Fortran compilers.
- pkgver = 2.9.2
+ pkgver = 2.10.1
pkgrel = 1
- url = http://www.opencoarrays.org/
+ url = https://github.com/sourceryinstitute/OpenCoarrays
arch = x86_64
license = BSD
makedepends = cmake
depends = mpich
depends = gcc-fortran
- source = https://github.com/sourceryinstitute/opencoarrays/releases/download/2.9.2/opencoarrays-2.9.2.tar.gz
- source = https://github.com/sourceryinstitute/opencoarrays/releases/download/2.9.2/opencoarrays-2.9.2.tar.gz.asc
- validpgpkeys = 1DB1B5EDE32122B28E56810DCB21118C92A64702
- validpgpkeys = 9DB31CF0FF5209BF742555701C3986CA8C98C2DE
- sha256sums = 6c200ca49808c75b0a2dfa984304643613b6bc77cc0044bee093f9afe03698f7
- sha256sums = SKIP
+ conflicts = opencoarrays-git
+ source = https://github.com/sourceryinstitute/OpenCoarrays/releases/download/2.10.1/OpenCoarrays-2.10.1.tar.gz
+ sha256sums = b04b8fa724e7e4e5addbab68d81d701414e713ab915bafdf1597ec5dd9590cd4
pkgname = opencoarrays
-
diff --git a/PKGBUILD b/PKGBUILD
index a11c115f418a..16bd7879a376 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,47 +1,65 @@
-# Maintainer: koubekjan <koubekjan (a) protonmail dot com>
-# Contributor: physkets <physkets // at // tutanota dot com>
-# Contributor: James Clark <s1127853@sms.ed.ac.uk>
-pkgname=opencoarrays
-pkgver=2.9.2
+# Maintainer: banana-bred <j.forer@posteo.net>
+
+pkgname='opencoarrays'
+_name='OpenCoarrays'
+pkgver=2.10.1
pkgrel=1
pkgdesc="A transport layer for coarray Fortran compilers."
-url="http://www.opencoarrays.org/"
arch=('x86_64')
+url="https://github.com/sourceryinstitute/OpenCoarrays"
license=('BSD')
+groups=()
depends=('mpich' 'gcc-fortran')
makedepends=('cmake')
-source=("https://github.com/sourceryinstitute/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz"{,.asc})
-validpgpkeys=('1DB1B5EDE32122B28E56810DCB21118C92A64702' # Izaak Beekman <zbeekman@gmail.com>
- '9DB31CF0FF5209BF742555701C3986CA8C98C2DE') # Damian Rouson <damian@sourceryinstitute.org>
-sha256sums=('6c200ca49808c75b0a2dfa984304643613b6bc77cc0044bee093f9afe03698f7'
- 'SKIP' )
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=("${pkgname}-git")
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+noextract=()
+source=("https://github.com/sourceryinstitute/OpenCoarrays/releases/download/${pkgver}/OpenCoarrays-${pkgver}.tar.gz")
+sha256sums=('b04b8fa724e7e4e5addbab68d81d701414e713ab915bafdf1597ec5dd9590cd4')
build() {
- export PATH="/opt/mpich/bin:$PATH"
- export LD_LIBRARY_PATH="/opt/mpich/lib:${LD_LIBRARY_PATH}"
- cd "${srcdir}/OpenCoarrays-${pkgver}"
- mkdir -p build
- cd build
- CC=gcc FC=gfortran cmake .. \
+
+ cd "${srcdir}/${_name}-${pkgver}"
+
+ export FC="$(command -v gfortran)"
+ export CC="$(command -v gcc)"
+ cmake \
+ -B build \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DMPI_C_COMPILER=/opt/mpich/bin/mpicc \
- -DMPI_Fortran_COMPILER=/opt/mpich/bin/mpifort
+ -DMPI_Fortran_COMPILER=/opt/mpich/bin/mpifort \
+ -DMPIEXEC_EXECUTABLE=/opt/mpich/bin/mpiexec
+
+ cd "${srcdir}/${_name}-${pkgver}/build"
make
+
}
check() {
- export PATH="/opt/mpich/bin:$PATH"
- export LD_LIBRARY_PATH="/opt/mpich/lib:${LD_LIBRARY_PATH}"
- cd "${srcdir}/OpenCoarrays-${pkgver}/build"
+
+ cd "${srcdir}/${_name}-${pkgver}/build"
+
make test
+
}
package() {
- cd "${srcdir}/OpenCoarrays-${pkgver}/build"
+
+ cd "${srcdir}/${_name}-${pkgver}/build"
+
make DESTDIR="${pkgdir}" install
- install -D -m644 ../LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ install -D -m 644 ../LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
}
-# vim:set ts=2 sw=2 et:
+# vim: ts=2 sw=2 et :