summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorColin Duquesnoy2016-01-25 19:46:39 +0100
committerColin Duquesnoy2016-01-25 19:55:01 +0100
commit2130a5b5b31edaa9b4468480dae1109edbc41093 (patch)
tree725cada314c4a935971c9fa7a3caf87ae714c502
downloadaur-2130a5b5b31edaa9b4468480dae1109edbc41093.tar.gz
Initial commit, v4.7.0
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD18
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9f8680dd5d1a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Mon Jan 25 18:50:52 UTC 2016
+pkgbase = opencobolide
+ pkgdesc = A simple and lightweight COBOL IDE based on the GnuCOBOL compiler.
+ pkgver = 4.7.0
+ pkgrel = 1
+ url = https://github.com/OpenCobolIDE/OpenCobolIDE
+ arch = any
+ license = GPL
+ makedepends = python-setuptools
+ depends = python
+ depends = python-pyqt5
+ depends = gnu-cobol
+ source = https://github.com/OpenCobolIDE/OpenCobolIDE/archive/4.7.0.tar.gz
+ md5sums = 62f41a1e07cd445ba1881b19e3672f86
+
+pkgname = opencobolide
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fde5831bd1ce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Colin Duquesnoy <colin[dot]duquesnoy[at]gmail[dot]com>
+pkgname=opencobolide
+pkgver=4.7.0
+pkgrel=1
+pkgdesc="A simple and lightweight COBOL IDE based on the GnuCOBOL compiler."
+arch=("any")
+url="https://github.com/OpenCobolIDE/OpenCobolIDE"
+license=("GPL")
+depends=("python" "python-pyqt5" "gnu-cobol")
+makedepends=("python-setuptools")
+source=("https://github.com/OpenCobolIDE/OpenCobolIDE/archive/${pkgver}.tar.gz")
+md5sums=('62f41a1e07cd445ba1881b19e3672f86')
+
+
+package() {
+ cd "$srcdir/OpenCobolIDE-$pkgver"
+ python3 setup.py install --root="$pkgdir/" --optimize=1
+}