summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrien Jussak2020-04-01 18:07:02 +0200
committerAdrien Jussak2020-04-01 18:07:02 +0200
commit34418c8b5a8cd3a90ecc1e97bfac43214e47a83d (patch)
tree3f42c848b688b22b05662907a4157fde4b2dec66
parentd526f10a3e2b8b6f67804d578d33142181047105 (diff)
downloadaur-34418c8b5a8cd3a90ecc1e97bfac43214e47a83d.tar.gz
ArchLinux Compatibility Patch
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
-rw-r--r--arch-compatibility.patch13
3 files changed, 23 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b93fd1c8e078..c45269aa9925 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Sat Jan 14 17:28:23 UTC 2017
pkgbase = opencobolide
pkgdesc = A simple and lightweight COBOL IDE based on the GnuCOBOL compiler.
pkgver = 4.7.6
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/OpenCobolIDE/OpenCobolIDE
arch = any
license = GPL
@@ -12,7 +10,9 @@ pkgbase = opencobolide
depends = python-pyqt5
depends = gnu-cobol
source = https://github.com/OpenCobolIDE/OpenCobolIDE/archive/4.7.6.tar.gz
- md5sums = 95abb1245b8ec5338ef9c5a579c9144a
+ source = arch-compatibility.patch
+ md5sums = ca7199d3a06d54306b054c862e24c9dc
+ md5sums = 492c90dffec11d9a2e70544ef821a9ef
pkgname = opencobolide
diff --git a/PKGBUILD b/PKGBUILD
index 865cd7f26036..9478efb1e542 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,20 @@
# Maintainer: Colin Duquesnoy <colin[dot]duquesnoy[at]gmail[dot]com>
pkgname=opencobolide
pkgver=4.7.6
-pkgrel=1
+pkgrel=2
pkgdesc="A simple and lightweight COBOL IDE based on the GnuCOBOL compiler."
arch=("any")
url="https://github.com/OpenCobolIDE/OpenCobolIDE"
license=("GPL")
depends=("python" "python-pyqt5" "gnu-cobol")
makedepends=("python-setuptools")
-source=("https://github.com/OpenCobolIDE/OpenCobolIDE/archive/${pkgver}.tar.gz")
-md5sums=('ca7199d3a06d54306b054c862e24c9dc')
-
+source=("https://github.com/OpenCobolIDE/OpenCobolIDE/archive/${pkgver}.tar.gz"
+ "arch-compatibility.patch")
+md5sums=('ca7199d3a06d54306b054c862e24c9dc'
+ '492c90dffec11d9a2e70544ef821a9ef')
package() {
cd "$srcdir/OpenCobolIDE-$pkgver"
+ patch --forward --strip=1 --input="${srcdir}/arch-compatibility.patch"
python3 setup.py install --root="$pkgdir/" --optimize=1
}
diff --git a/arch-compatibility.patch b/arch-compatibility.patch
new file mode 100644
index 000000000000..321e43c7c44c
--- /dev/null
+++ b/arch-compatibility.patch
@@ -0,0 +1,13 @@
+diff --git a/open_cobol_ide/system.py b/open_cobol_ide/system.py
+index 5d1e50b..9e072c2 100644
+--- a/open_cobol_ide/system.py
++++ b/open_cobol_ide/system.py
+@@ -16,7 +16,7 @@ windows = platform.system() == 'Windows'
+ darwin = platform.system() == 'Darwin'
+ linux = platform.system() == 'Linux'
+ if linux:
+- ubuntu = platform.linux_distribution()[0].lower() == 'ubuntu'
++ ubuntu = True
+ else:
+ ubuntu = False
+