summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTércio Martins2021-01-15 20:56:00 -0300
committerTércio Martins2021-01-15 20:56:00 -0300
commit3cad0f9cab613cac3c940e0d94f0ff4b59721f93 (patch)
tree95e4cd8bc905fd0cdc3212abf56303edd7b03555
parentf6e89da50b86182702b3a129b939ea32263abde8 (diff)
downloadaur-3cad0f9cab613cac3c940e0d94f0ff4b59721f93.tar.gz
Update dependency list
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD19
2 files changed, 15 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3296f0ef1ef0..466767a4ab01 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = opencolorio-git
pkgdesc = A color management framework for visual effects and animation
- pkgver = 1.0.8.r542.g98321505
+ pkgver = 1.0.8.r572.gd71748bf
pkgrel = 1
url = https://opencolorio.org
arch = x86_64
@@ -10,12 +10,12 @@ pkgbase = opencolorio-git
makedepends = git
makedepends = pybind11
makedepends = python
- makedepends = tinyxml
depends = freeglut
depends = glew
depends = lcms2
depends = openexr
depends = pystring
+ depends = tinyxml
depends = yaml-cpp
optdepends = python: python bindings
provides = opencolorio
diff --git a/PKGBUILD b/PKGBUILD
index d530821a24d2..0f28f95e5f26 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@
_pkgname=OpenColorIO
pkgname=${_pkgname,,}-git
-pkgver=1.0.8.r542.g98321505
+pkgver=1.0.8.r572.gd71748bf
pkgrel=1
pkgdesc="A color management framework for visual effects and animation"
arch=('x86_64')
url="https://opencolorio.org"
license=('BSD')
-depends=('freeglut' 'glew' 'lcms2' 'openexr' 'pystring' 'yaml-cpp')
-makedepends=('boost' 'cmake' 'git' 'pybind11' 'python' 'tinyxml')
+depends=('freeglut' 'glew' 'lcms2' 'openexr' 'pystring' 'tinyxml' 'yaml-cpp')
+makedepends=('boost' 'cmake' 'git' 'pybind11' 'python')
optdepends=('python: python bindings')
provides=('opencolorio')
conflicts=('opencolorio')
@@ -23,14 +23,21 @@ pkgver() {
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
+prepare(){
+ mkdir -p $_pkgname/build
+ sed -i '/Global CMake options/ a find_package(Threads REQUIRED)' $_pkgname/CMakeLists.txt
+}
+
build() {
- cd $_pkgname
+ cd $_pkgname/build
- mkdir -p build && cd build
cmake .. \
+ -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
- -DOCIO_INSTALL_EXT_PACKAGES=NONE
+ -DOCIO_BUILD_APPS=OFF \
+ -DOCIO_BUILD_TESTS=OFF \
+ -DOCIO_BUILD_GPU_TESTS=OFF
make
}