diff options
author | peelz | 2024-12-17 13:48:16 -0500 |
---|---|---|
committer | peelz | 2024-12-17 14:03:59 -0500 |
commit | ec56a0bac247ffbdc380788052cbc68f103c1b35 (patch) | |
tree | 1efa98e8bbda0ad36e073436bb2bed1e561d09c7 | |
parent | 9899f52c3f66fb4e7f40f54bf6cabcea538ef359 (diff) | |
download | aur-ec56a0bac247ffbdc380788052cbc68f103c1b35.tar.gz |
style: formatting
-rw-r--r-- | PKGBUILD | 48 |
1 files changed, 31 insertions, 17 deletions
@@ -1,30 +1,42 @@ # vim:ts=2:sw=2:expandtab # Maintainer: peelz <peelz.dev+arch@gmail.com> -pkgname=opencomposite-git -pkgver=r1074.356d039 -pkgrel=1 -pkgdesc='Reimplementation of OpenVR, translating calls to OpenXR.' -arch=('x86_64') -url='https://gitlab.com/znixian/OpenOVR' -license=('GPL3') -depends=('vulkan-icd-loader' 'glm') -makedepends=('git' 'cmake' 'make' 'vulkan-headers') +pkgname="opencomposite-git" +pkgver="r1074.356d039" +pkgrel="1" +pkgdesc="Reimplementation of OpenVR, translating calls to OpenXR." +arch=("x86_64") +url="https://gitlab.com/znixian/OpenOVR" +license=("GPL3") +depends=( + "vulkan-icd-loader" + "glm" +) +makedepends=( + "git" + "cmake" + "make" + "vulkan-headers" +) provides=("opencomposite") conflicts=("opencomposite") -source=("${pkgname}::git+${url}#branch=openxr" - "git+https://github.com/KhronosGroup/OpenXR-SDK" - "git+https://github.com/g-truc/glm") -sha1sums=('SKIP' - 'SKIP' - 'SKIP') +source=( + "${pkgname}::git+${url}#branch=openxr" + "git+https://github.com/KhronosGroup/OpenXR-SDK" + "git+https://github.com/g-truc/glm" +) +sha1sums=( + "SKIP" + "SKIP" + "SKIP" +) pkgver() { cd "${srcdir}/${pkgname}" printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)" } -prepare() { +prepare() { cd "${srcdir}/${pkgname}" git submodule init git config submodule.libs/openxr-sdk.url "${srcdir}/OpenXR-SDK" @@ -41,5 +53,7 @@ build() { } package() { - install -Dm755 ${srcdir}/${pkgname}/build/bin/linux64/vrclient.so ${pkgdir}/usr/share/opencomposite/bin/linux64/vrclient.so + install -Dm755 \ + "${srcdir}/${pkgname}/build/bin/linux64/vrclient.so" \ + "${pkgdir}/usr/share/opencomposite/bin/linux64/vrclient.so" } |