summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpeelz2024-12-17 13:48:16 -0500
committerpeelz2024-12-17 14:03:59 -0500
commitec56a0bac247ffbdc380788052cbc68f103c1b35 (patch)
tree1efa98e8bbda0ad36e073436bb2bed1e561d09c7
parent9899f52c3f66fb4e7f40f54bf6cabcea538ef359 (diff)
downloadaur-ec56a0bac247ffbdc380788052cbc68f103c1b35.tar.gz
style: formatting
-rw-r--r--PKGBUILD48
1 files changed, 31 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ab6b20493019..38fd5feafd9c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,42 @@
# vim:ts=2:sw=2:expandtab
# Maintainer: peelz <peelz.dev+arch@gmail.com>
-pkgname=opencomposite-git
-pkgver=r1074.356d039
-pkgrel=1
-pkgdesc='Reimplementation of OpenVR, translating calls to OpenXR.'
-arch=('x86_64')
-url='https://gitlab.com/znixian/OpenOVR'
-license=('GPL3')
-depends=('vulkan-icd-loader' 'glm')
-makedepends=('git' 'cmake' 'make' 'vulkan-headers')
+pkgname="opencomposite-git"
+pkgver="r1074.356d039"
+pkgrel="1"
+pkgdesc="Reimplementation of OpenVR, translating calls to OpenXR."
+arch=("x86_64")
+url="https://gitlab.com/znixian/OpenOVR"
+license=("GPL3")
+depends=(
+ "vulkan-icd-loader"
+ "glm"
+)
+makedepends=(
+ "git"
+ "cmake"
+ "make"
+ "vulkan-headers"
+)
provides=("opencomposite")
conflicts=("opencomposite")
-source=("${pkgname}::git+${url}#branch=openxr"
- "git+https://github.com/KhronosGroup/OpenXR-SDK"
- "git+https://github.com/g-truc/glm")
-sha1sums=('SKIP'
- 'SKIP'
- 'SKIP')
+source=(
+ "${pkgname}::git+${url}#branch=openxr"
+ "git+https://github.com/KhronosGroup/OpenXR-SDK"
+ "git+https://github.com/g-truc/glm"
+)
+sha1sums=(
+ "SKIP"
+ "SKIP"
+ "SKIP"
+)
pkgver() {
cd "${srcdir}/${pkgname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
}
-prepare() {
+prepare() {
cd "${srcdir}/${pkgname}"
git submodule init
git config submodule.libs/openxr-sdk.url "${srcdir}/OpenXR-SDK"
@@ -41,5 +53,7 @@ build() {
}
package() {
- install -Dm755 ${srcdir}/${pkgname}/build/bin/linux64/vrclient.so ${pkgdir}/usr/share/opencomposite/bin/linux64/vrclient.so
+ install -Dm755 \
+ "${srcdir}/${pkgname}/build/bin/linux64/vrclient.so" \
+ "${pkgdir}/usr/share/opencomposite/bin/linux64/vrclient.so"
}