summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoruli2022-10-03 22:32:08 +0200
committeruli2022-10-03 22:32:08 +0200
commit036bca7edc5fd1e898075b2f8df96a200478d67e (patch)
treef059d5876cee6f588bda1fe0b85f0c27294a27c7
parent260bade20d0bbc8ea00064912adbd7fe6c93cb28 (diff)
downloadaur-036bca7edc5fd1e898075b2f8df96a200478d67e.tar.gz
updated to v1.4.46.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD30
-rw-r--r--gl.patch13
3 files changed, 30 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 767e51cea436..aad8dc41de8d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = opencpn-plugin-climatology
pkgdesc = Climatology plugin for OpenCPN
- pkgver = 1.4.2.ov50.r0.gc4e6050
+ pkgver = 1.4.46.0
pkgrel = 1
url = https://opencpn.org/OpenCPN/plugins/climatology.html
arch = x86_64
@@ -9,8 +9,9 @@ pkgbase = opencpn-plugin-climatology
makedepends = cmake
makedepends = git
depends = opencpn
- source = opencpn-plugin-climatology::git+https://github.com/rgleason/climatology_pi.git
- sha1sums = SKIP
+ source = opencpn-plugin-climatology-1.4.46.0::https://github.com/rgleason/climatology_pi/archive/refs/tags/v1.4.46.0.tar.gz
+ source = gl.patch
+ b2sums = 79bdc314fb0b8179dd2884ac94b1c32346887358683a462ddd0fa28e231f709c432b07313bc5dd786e874bb76b1726d7f8ed496bd582e3a538aae38c98fbcccd
+ b2sums = 9b12e9a5701a0d074265d15d50350db4d2526f1bfa7baec0b78b4f38fdd9b1e5bc77199ad337599aa28a7fa8a253246d8c764a2b3fbc2f47fc595fdb23f59306
pkgname = opencpn-plugin-climatology
-
diff --git a/PKGBUILD b/PKGBUILD
index f767bd61ffd0..5ec9f87584e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,8 @@
-# ---------------------------------------------------------------
-# Maintainer: Romain Bazile <gromain.baz@gmail.com>
-# ---------------------------------------------------------------
+# Maintainer: cybuzuma <cybuzuma at vnxs dot de>
+# Contributor: Romain Bazile <gromain.baz@gmail.com>
pkgname=opencpn-plugin-climatology
-pkgver=1.4.2.ov50.r0.gc4e6050
+pkgver=1.4.46.0
pkgrel=1
pkgdesc="Climatology plugin for OpenCPN"
arch=('x86_64' 'aarch64')
@@ -11,31 +10,26 @@ license=("GPL3")
depends=('opencpn')
makedepends=('cmake' 'git')
url="https://opencpn.org/OpenCPN/plugins/climatology.html"
-source=("$pkgname::git+https://github.com/rgleason/climatology_pi.git")
-sha1sums=('SKIP')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/rgleason/climatology_pi/archive/refs/tags/v$pkgver.tar.gz" "gl.patch")
+b2sums=('79bdc314fb0b8179dd2884ac94b1c32346887358683a462ddd0fa28e231f709c432b07313bc5dd786e874bb76b1726d7f8ed496bd582e3a538aae38c98fbcccd' '9b12e9a5701a0d074265d15d50350db4d2526f1bfa7baec0b78b4f38fdd9b1e5bc77199ad337599aa28a7fa8a253246d8c764a2b3fbc2f47fc595fdb23f59306')
-pkgver() {
- cd $pkgname
- git describe --long --tags | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
-}
prepare(){
- cd ${srcdir}/${pkgname}
- git submodule init
- git submodule sync
- git submodule update
- rm data/.git
+ cd climatology_pi-$pkgver
+ git submodule update --init
+ patch --strip=1 --input=../gl.patch
}
build() {
- cd ${srcdir}/${pkgname}
+ cd climatology_pi-$pkgver
mkdir -p build
cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config-gtk3 ..
+ #Force GTK3, suppress cmake warnings, allow C++11
+ BUILD_GTK3=TRUE cmake -Wno-dev -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DPlugin_CXX11=ON ..
make
}
package() {
- cd "${pkgname}/build"
+ cd climatology_pi-$pkgver/build
DESTDIR="$pkgdir" make install
}
diff --git a/gl.patch b/gl.patch
new file mode 100644
index 000000000000..de4ab92030f8
--- /dev/null
+++ b/gl.patch
@@ -0,0 +1,13 @@
+diff --git a/src/ClimatologyOverlayFactory.cpp b/src/ClimatologyOverlayFactory.cpp
+index ad40891..0648f31 100644
+--- a/src/ClimatologyOverlayFactory.cpp
++++ b/src/ClimatologyOverlayFactory.cpp
+@@ -28,6 +28,8 @@
+ #include <wx/wx.h>
+ #include <wx/glcanvas.h>
+
++#include <GL/glx.h>
++
+ #ifdef __WXOSX__
+ # include <OpenGL/OpenGL.h>
+ # include <OpenGL/gl3.h>