summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRomain Bazile2020-07-03 14:49:15 +0200
committerRomain Bazile2020-07-03 14:49:15 +0200
commitf489c1c197aed2eaefe7bd9c91c390d8d9bbda41 (patch)
tree150e9cc573df78aecc266f3d54527a626dadae5a
downloadaur-f489c1c197aed2eaefe7bd9c91c390d8d9bbda41.tar.gz
first release
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD34
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8110e9b88ada
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = opencpn-plugin-oesenc-git
+ pkgdesc = O-charts.org plugin for OpenCPN
+ pkgver = 4.0.5.r112.gaa16607
+ pkgrel = 1
+ url = https://opencpn.org/OpenCPN/plugins/oesenc.html
+ arch = x86_64
+ arch = aarch64
+ license = GPL3
+ makedepends = cmake
+ makedepends = git
+ depends = opencpn
+ conflicts = opencpn-plugin-oesenc
+ source = opencpn-plugin-oesenc-git::git+https://github.com/bdbcat/oesenc_pi.git
+ sha1sums = SKIP
+
+pkgname = opencpn-plugin-oesenc-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..48ec7e412ee9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# ---------------------------------------------------------------
+# Maintainer: Romain Bazile <gromain.baz@gmail.com>
+# ---------------------------------------------------------------
+
+pkgname=opencpn-plugin-oesenc-git
+pkgver=4.0.5.r112.gaa16607
+pkgrel=1
+pkgdesc="O-charts.org plugin for OpenCPN"
+arch=('x86_64' 'aarch64')
+license=("GPL3")
+depends=('opencpn')
+conflicts=('opencpn-plugin-oesenc')
+makedepends=('cmake' 'git')
+url="https://opencpn.org/OpenCPN/plugins/oesenc.html"
+source=("$pkgname::git+https://github.com/bdbcat/oesenc_pi.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --long --tags | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $pkgname
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config-gtk3 ..
+ make
+}
+
+package() {
+ cd "$pkgname/build"
+ DESTDIR="$pkgdir" make install
+}