summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoruli2023-04-24 22:52:00 +0200
committeruli2023-04-24 22:52:00 +0200
commit814fdc85d3731030276f5ed1326aac3ebf1a8169 (patch)
tree434630c0b14462b742eae8444932bc1866e63f8c
parentbf66ebd0db7478bc11be0fb3f2e9a590d3c0f7f8 (diff)
downloadaur-814fdc85d3731030276f5ed1326aac3ebf1a8169.tar.gz
v1.9.56.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD23
2 files changed, 13 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c9fe61d99631..84505a364d55 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = opencpn-plugin-weatherfax
pkgdesc = Open image files directly, or decode audio faxes to an image. Plugin for OpenCPN.
- pkgver = 1.3.r220.g48a8f90
+ pkgver = 1.9.56.0
pkgrel = 1
url = https://opencpn.org/OpenCPN/plugins/weatherfax.html
arch = x86_64
@@ -9,8 +9,8 @@ pkgbase = opencpn-plugin-weatherfax
makedepends = cmake
makedepends = git
depends = opencpn
- source = opencpn-plugin-weatherfax::git+https://github.com/seandepagnier/weatherfax_pi.git
- sha1sums = SKIP
+ optdepends = rtl-sdr: decode from rtlsdr
+ source = opencpn-plugin-weatherfax-1.9.56.0.tar.gz::https://github.com/rgleason/weatherfax_pi/archive/refs/tags/v1.9.56.0.tar.gz
+ b2sums = 05d5d3bd1557fdc4a407d79e504478fcf8c9a800d181bfd2ac8f9ef988a564cadb18318a69cb61454cf9ddc88f62c247054280d081cb6bc189a558cb73199989
pkgname = opencpn-plugin-weatherfax
-
diff --git a/PKGBUILD b/PKGBUILD
index 102e38bfa2f4..4a0e7192d828 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,28 @@
-# ---------------------------------------------------------------
-# Maintainer: Romain Bazile <gromain.baz@gmail.com>
-# ---------------------------------------------------------------
+# Maintainer: cybuzuma <cybuzuma at vnxs dot de>
+# Contributor: Romain Bazile <gromain.baz@gmail.com>
pkgname=opencpn-plugin-weatherfax
-pkgver=1.3.r220.g48a8f90
+pkgver=1.9.56.0
pkgrel=1
pkgdesc="Open image files directly, or decode audio faxes to an image. Plugin for OpenCPN."
arch=('x86_64' 'aarch64')
license=("GPL3")
depends=('opencpn')
+optdepends=('rtl-sdr: decode from rtlsdr')
makedepends=('cmake' 'git')
url="https://opencpn.org/OpenCPN/plugins/weatherfax.html"
-source=("$pkgname::git+https://github.com/seandepagnier/weatherfax_pi.git")
-sha1sums=('SKIP')
-
-pkgver() {
- cd $pkgname
- git describe --long --tags | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
-}
+source=("$pkgname-$pkgver.tar.gz::https://github.com/rgleason/weatherfax_pi/archive/refs/tags/v$pkgver.tar.gz")
+b2sums=('05d5d3bd1557fdc4a407d79e504478fcf8c9a800d181bfd2ac8f9ef988a564cadb18318a69cb61454cf9ddc88f62c247054280d081cb6bc189a558cb73199989')
build() {
- cd $pkgname
+ cd weatherfax_pi-$pkgver
mkdir -p build
cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config-gtk3 ../
+ BUILD_GTK3=TRUE cmake -Wno-dev -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DPlugin_CXX11=ON -DUSE_GL=ON ..
make
}
package() {
- cd "$pkgname/build"
+ cd weatherfax_pi-$pkgver/build
DESTDIR="$pkgdir" make install
}