summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRomain Bazile2019-05-23 15:02:58 +0200
committerRomain Bazile2019-05-23 15:02:58 +0200
commit35293613c624d0a37cdb225ce54495b59eac29e7 (patch)
treed429e10a63dde154391b792a5f130677342303bf
downloadaur-35293613c624d0a37cdb225ce54495b59eac29e7.tar.gz
Initial release of weather routing plugin for OpenCPN
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9adcfca44834
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = opencpn-plugin-weatherrouting
+ pkgdesc = Weather routing plugin for OpenCPN
+ pkgver = 1.10.1
+ pkgrel = 1
+ url = https://opencpn.org/OpenCPN/plugins/weatherroute.html
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ depends = opencpn
+ source = https://github.com/seandepagnier/weather_routing_pi/archive/v1.10.1.tar.gz
+ sha1sums = be3c5d7ee096aa19767cd0c7cf851186785ac387
+
+pkgname = opencpn-plugin-weatherrouting
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..56a630dc453e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# ---------------------------------------------------------------
+# Maintainer: Romain Bazile <gromain.baz at gmail dot com>
+# ---------------------------------------------------------------
+
+pkgname=opencpn-plugin-weatherrouting
+pkgver=1.10.1
+pkgrel=1
+pkgdesc="Weather routing plugin for OpenCPN"
+arch=('x86_64')
+license=("GPL3")
+depends=('opencpn')
+makedepends=('cmake')
+url="https://opencpn.org/OpenCPN/plugins/weatherroute.html"
+source=("https://github.com/seandepagnier/weather_routing_pi/archive/v${pkgver}.tar.gz")
+sha1sums=('be3c5d7ee096aa19767cd0c7cf851186785ac387')
+
+build() {
+ cd "weather_routing_pi-${pkgver}"
+ mkdir -p build
+ cd build
+ cmake ..
+ make
+}
+
+package() {
+ cd "weather_routing_pi-${pkgver}/build"
+ DESTDIR="$pkgdir" make install
+}