summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Dewar2020-03-01 10:03:31 +0000
committerAlex Dewar2020-03-01 10:03:31 +0000
commitda46f6d98745a8dd413e86d674d729b93c7d8de6 (patch)
tree408fe2b7d398c94a799e4d0b3273ba3935ef8f1b
parent6f02da081e3bc6ad66696b2545b50b1cb125b427 (diff)
downloadaur-da46f6d98745a8dd413e86d674d729b93c7d8de6.tar.gz
Fix build
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
-rw-r--r--fix-cuda-10.1.patch37
3 files changed, 4 insertions, 55 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 088b19cf4b6e..171702a30b74 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = opencv-cuda
pkgdesc = Open Source Computer Vision Library with CUDA support
pkgver = 4.2.0
- pkgrel = 1
+ pkgrel = 2
url = http://opencv.org/
arch = x86_64
license = BSD
@@ -36,12 +36,8 @@ pkgbase = opencv-cuda
options = staticlibs
source = opencv-4.2.0.tar.gz::https://github.com/opencv/opencv/archive/4.2.0.zip
source = opencv_contrib-4.2.0.tar.gz::https://github.com/opencv/opencv_contrib/archive/4.2.0.tar.gz
- source = fix-cuda-10.1.patch
- source = fix-build-error.patch::https://github.com/opencv/opencv_contrib/commit/00e60f0d578651540b709730aa284af54055ae97.patch
sha256sums = 55bd939079d141a50fca74bde5b61b339dd0f0ece6320ec76859aaff03c90d9f
sha256sums = 8a6b5661611d89baa59a26eb7ccf4abb3e55d73f99bb52d8f7c32265c8a43020
- sha256sums = 4e1640f37ee357d38551a65d3dbfc03a5d7589bffaa3cde92a64c5ea62f55aef
- sha256sums = 805166b77b0c38e9e9f69b5b285d2b5313e54f0419a71155f4d9f2d5e6b5d2cc
pkgname = opencv-cuda
diff --git a/PKGBUILD b/PKGBUILD
index 8c4a6676b367..7d488e7bbe50 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=opencv-cuda
pkgver=4.2.0
-pkgrel=1
+pkgrel=2
provides=(opencv opencv-samples)
conflicts=(opencv opencv-samples)
pkgdesc="Open Source Computer Vision Library with CUDA support"
@@ -21,25 +21,15 @@ optdepends=('opencv-samples: samples'
'python-numpy: Python 3 interface'
'python2-numpy: Python 2 interface')
source=("opencv-$pkgver.tar.gz::https://github.com/opencv/opencv/archive/$pkgver.zip"
- "opencv_contrib-$pkgver.tar.gz::https://github.com/opencv/opencv_contrib/archive/$pkgver.tar.gz"
- "fix-cuda-10.1.patch"
- "fix-build-error.patch::https://github.com/opencv/opencv_contrib/commit/00e60f0d578651540b709730aa284af54055ae97.patch")
+ "opencv_contrib-$pkgver.tar.gz::https://github.com/opencv/opencv_contrib/archive/$pkgver.tar.gz")
sha256sums=('55bd939079d141a50fca74bde5b61b339dd0f0ece6320ec76859aaff03c90d9f'
- '8a6b5661611d89baa59a26eb7ccf4abb3e55d73f99bb52d8f7c32265c8a43020'
- '4e1640f37ee357d38551a65d3dbfc03a5d7589bffaa3cde92a64c5ea62f55aef'
- '805166b77b0c38e9e9f69b5b285d2b5313e54f0419a71155f4d9f2d5e6b5d2cc')
+ '8a6b5661611d89baa59a26eb7ccf4abb3e55d73f99bb52d8f7c32265c8a43020')
prepare() {
msg2 "Patching sources for CUDA v10"
sed -i 's|nvcuvid.h|nvidia-sdk/nvcuvid.h|' opencv_contrib-$pkgver/modules/cud*/src/*.hpp
mkdir -p build
-
- cd opencv-$pkgver
- patch --forward --strip=1 < ../fix-cuda-10.1.patch
-
- cd ../opencv_contrib-$pkgver
- patch --forward --strip=1 < ../fix-build-error.patch
}
build() {
diff --git a/fix-cuda-10.1.patch b/fix-cuda-10.1.patch
deleted file mode 100644
index 7065b731c1f6..000000000000
--- a/fix-cuda-10.1.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From b32ba55150c5d678836a80700a126dae8c5b67f8 Mon Sep 17 00:00:00 2001
-From: Chuan Qin <qc2105@qq.com>
-Date: Fri, 1 Mar 2019 23:48:15 +0800
-Subject: [PATCH] workaround to 'fix' issues with
- ubuntu-18.04/cuda-10.1/g++5.5.0/GeForce RTX 2080 Ti
-
----
- .../core/include/opencv2/core/cvstd_wrapper.hpp | 14 ++++++++------
- 1 file changed, 8 insertions(+), 6 deletions(-)
-
-diff --git a/modules/core/include/opencv2/core/cvstd_wrapper.hpp b/modules/core/include/opencv2/core/cvstd_wrapper.hpp
-index a65dfd4bd37..1a7cf1cae7d 100644
---- a/modules/core/include/opencv2/core/cvstd_wrapper.hpp
-+++ b/modules/core/include/opencv2/core/cvstd_wrapper.hpp
-@@ -27,14 +27,16 @@ Ptr<_Tp> makePtr(const A1&... a1) { return std::make_shared<_Tp>(a1...); }
-
- #else // cv::Ptr with compatibility workarounds
-
--// It should be defined for C-API types only.
--// C++ types should use regular "delete" operator.
--template<typename Y> struct DefaultDeleter;
--#if 0
-+template<typename Y>
-+struct DefaultDeleter
- {
-- void operator()(Y* p) const;
--};
-+#ifndef _MSC_VER
-+ void operator()(Y* p) const = delete; // not available by default; enabled for specializations only
-+#else
-+ void operator()(Y* p) const { delete p; }
- #endif
-+};
-+
-
- namespace sfinae {
- template<typename C, typename Ret, typename... Args>