summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScore_Under2018-11-29 02:42:08 +0000
committerScore_Under2018-11-29 02:46:52 +0000
commitc6208407511dac1325989c10e633e4a3de0b1ac9 (patch)
treedbff05ffee89c6604c54a926d5f76759441ad965
parent2972770eec7b703fbfd7963630f0c691e870d7cc (diff)
downloadaur-c6208407511dac1325989c10e633e4a3de0b1ac9.tar.gz
The AUR made me do this with its commit hooks
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03f615dc5491..5f9bb16db5a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
# Generated by mksrcinfo v8
-# Thu Nov 29 02:39:03 UTC 2018
-pkgbase = opencv
+# Thu Nov 29 02:42:11 UTC 2018
+pkgbase = opencv-with-python2-support
pkgdesc = Open Source Computer Vision Library
pkgver = 4.0.0
pkgrel = 4
diff --git a/PKGBUILD b/PKGBUILD
index 76901c314e54..e8189aae93ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
# Maintainer: Ray Rashif <schiv@archlinux.org>
# Contributor: Tobias Powalowski <tpowa@archlinux.org>
-pkgbase=opencv
+pkgbase=opencv-with-python2-support
pkgname=(opencv-with-python2-support opencv-with-python2-support-samples)
pkgver=4.0.0
pkgrel=4
@@ -24,7 +24,7 @@ optdepends=('opencv-samples: samples'
'hdf5: support for HDF5 format'
'opencl-icd-loader: For coding with OpenCL'
'python-numpy: Python interface')
-source=("$pkgbase-$pkgver.tar.gz::https://github.com/opencv/opencv/archive/$pkgver.zip"
+source=("opencv-$pkgver.tar.gz::https://github.com/opencv/opencv/archive/$pkgver.zip"
"opencv_contrib-$pkgver.tar.gz::https://github.com/opencv/opencv_contrib/archive/$pkgver.tar.gz")
sha256sums=('86fd08fc02893e05e2944fa7b0daa7d02643232450f020b475e1b2f24587b99a'
'4fb0681414df4baedce6e3f4a01318d6f4fcde6ee14854d761fd4e397a397763')
@@ -44,7 +44,7 @@ build() {
# cmake's FindLAPACK doesn't add cblas to LAPACK_LIBRARIES, so we need to specify them manually
_python3path=`python -c "from sysconfig import get_path; print(get_path('platlib'))"`
_python2path=`python2 -c "from sysconfig import get_path; print(get_path('platlib'))"`
- cmake ../$pkgbase-$pkgver \
+ cmake ../opencv-$pkgver \
-DWITH_OPENCL=ON \
-DWITH_OPENGL=ON \
-DWITH_TBB=ON \
@@ -78,15 +78,15 @@ package_opencv-with-python2-support() {
make DESTDIR="$pkgdir" install
# install license file
- install -Dm644 "$srcdir"/$pkgbase-$pkgver/LICENSE -t "$pkgdir"/usr/share/licenses/$pkgbase
+ install -Dm644 "$srcdir"/opencv-$pkgver/LICENSE -t "$pkgdir"/usr/share/licenses/opencv
# separate samples package
cd "$pkgdir"/usr/share
- mv opencv4/samples "$srcdir"/$pkgbase-samples
+ mv opencv4/samples "$srcdir"/opencv-samples
# install missing headers https://github.com/opencv/opencv/issues/13201
for _module in imgcodecs videoio photo; do
- cp -r "$srcdir"/$pkgbase-$pkgver/modules/$_module/include/opencv2/$_module/legacy \
+ cp -r "$srcdir"/opencv-$pkgver/modules/$_module/include/opencv2/$_module/legacy \
"$pkgdir"/usr/include/opencv4/opencv2/$_module
done
}
@@ -104,5 +104,5 @@ package_opencv-with-python2-support-samples() {
chmod 755 "$pkgdir"/usr/share/opencv/samples/*
# install license file
- install -Dm644 "$srcdir"/opencv-$pkgver/LICENSE -t "$pkgdir"/usr/share/licenses/$pkgbase-samples
+ install -Dm644 "$srcdir"/opencv-$pkgver/LICENSE -t "$pkgdir"/usr/share/licenses/opencv-samples
}