summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorname2016-04-25 16:46:39 +0200
committername2016-04-25 16:46:39 +0200
commit430424b5d88976d6b70d2da9371d04c07729f07d (patch)
tree4de39dc46ca23a6538d1dee42cf472c64651215f
parent687987f08e233517f9859ea88b09546e15b53746 (diff)
downloadaur-430424b5d88976d6b70d2da9371d04c07729f07d.tar.gz
fixed pkgbase
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD19
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc67010a5ccc..de48b0a894fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,4 +1,4 @@
-pkgbase = opencv
+pkgbase = opencv2
pkgdesc = Open Source Computer Vision Library (Legacy Version)
pkgver = 2.4.12.3
pkgrel = 1
diff --git a/PKGBUILD b/PKGBUILD
index e4d440ad3ea9..443418af890e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,8 @@
# Contributor: Ray Rashif <schiv@archlinux.org>
# Contributor: Tobias Powalowski <tpowa@archlinux.org>
-pkgbase=opencv
+_pkgbase=opencv
+pkgbase=opencv2
pkgname=('opencv2' 'opencv2-samples')
pkgver=2.4.12.3
pkgrel=1
@@ -16,7 +17,7 @@ optdepends=('opencv-samples'
'eigen2'
'libcl: For coding with OpenCL'
'python2-numpy: Python 2.x interface')
-source=("$pkgbase-$pkgver.zip::https://github.com/Itseez/opencv/archive/$pkgver.zip" opencv-ffmpeg3.patch)
+source=("$_pkgbase-$pkgver.zip::https://github.com/Itseez/opencv/archive/$pkgver.zip" opencv-ffmpeg3.patch)
md5sums=('eaede6500e9c2d56683196b0576db1f7'
'c752f3e83ebb021171fdd04aa7fb2e5a')
@@ -45,13 +46,13 @@ _cmakeopts=('-D WITH_OPENCL=ON'
[[ "$CARCH" = 'x86_64' ]] && _cmakeopts+=('-D ENABLE_SSE3=OFF')
prepare() {
- cd $pkgbase-$pkgver
+ cd $_pkgbase-$pkgver
# Fix build with ffmpeg 3.0 (Debian)
patch -p1 -i ../opencv-ffmpeg3.patch
}
build() {
- cd "$srcdir/$pkgbase-$pkgver"
+ cd "$srcdir/$_pkgbase-$pkgver"
cmake ${_cmakeopts[@]} .
@@ -62,20 +63,20 @@ package_opencv2() {
options=('staticlibs')
conflicts=('opencv')
- cd "$srcdir/$pkgbase-$pkgver"
+ cd "$srcdir/$_pkgbase-$pkgver"
make DESTDIR="$pkgdir" install
# install license file
- install -Dm644 "$srcdir/$pkgbase-$pkgver/LICENSE" \
+ install -Dm644 "$srcdir/$_pkgbase-$pkgver/LICENSE" \
"$pkgdir/usr/share/licenses/$pkgname/LICENSE"
cd "$pkgdir/usr/share"
# separate samples package; also be -R friendly
if [[ -d OpenCV/samples ]]; then
- mv OpenCV/samples "$srcdir/$pkgbase-samples"
- mv OpenCV $pkgbase # otherwise folder naming is inconsistent
+ mv OpenCV/samples "$srcdir/$_pkgbase-samples"
+ mv OpenCV $_pkgbase # otherwise folder naming is inconsistent
elif [[ ! -d OpenCV ]]; then
warning "Directory naming issue; samples package may not be built!"
fi
@@ -87,7 +88,7 @@ package_opencv2-samples() {
unset optdepends
conflicts=('opencv-samples')
- mkdir -p "$pkgdir/usr/share/$pkgbase"
+ mkdir -p "$pkgdir/usr/share/$_pkgbase"
cp -r "$srcdir/opencv-samples" "$pkgdir/usr/share/opencv/samples"
# install license file