summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorE5ten2018-05-06 23:01:39 -0400
committerE5ten2018-05-06 23:01:39 -0400
commit7af1b6b48758d377c261977e048432119cbcc432 (patch)
tree4a065dff67a48fa7c57e17d8c710cc99cc58b53a
downloadaur-7af1b6b48758d377c261977e048432119cbcc432.tar.gz
initial
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
-rw-r--r--opendm.install7
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e05d9f4c8d11
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = opendm
+ pkgdesc = A simple GUI Display Manager written entirely in bash that uses xinit to start X sessions
+ pkgver = 0.0.2
+ pkgrel = 1
+ url = http://www.simonizor.net
+ install = opendm.install
+ arch = x86_64
+ license = MIT
+ depends = qarma
+ depends = xorg-xinit
+ source = https://github.com/simoniz0r/opendm/archive/v0.0.2.tar.gz
+ md5sums = 65145bc56c250d135cf2c5e29a40b677
+
+pkgname = opendm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a4a0af072200
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: E5ten
+
+pkgname=opendm
+_pkgname=OpenDM
+pkgver=0.0.2
+pkgrel=1
+pkgdesc="A simple GUI Display Manager written entirely in bash that uses xinit to start X sessions"
+arch=('x86_64')
+url='http://www.simonizor.net'
+license=('MIT')
+depends=('qarma' 'xorg-xinit')
+install=opendm.install
+source=("https://github.com/simoniz0r/$pkgname/archive/v$pkgver.tar.gz")
+md5sums=('65145bc56c250d135cf2c5e29a40b677')
+
+prepare() {
+ cd $srcdir
+ bsdtar xvf v$pkgver.tar.gz
+}
+
+package() {
+ cd $srcdir/$_pkgname-$pkgver
+ make DESTDIR="$pkgdir/" install
+} \ No newline at end of file
diff --git a/opendm.install b/opendm.install
new file mode 100644
index 000000000000..fc6391853f38
--- /dev/null
+++ b/opendm.install
@@ -0,0 +1,7 @@
+post_install() {
+ echo ">To start OpenDM on boot put this in your shell's profile e.g. ~/.bash_profile or ~/.zprofile."
+ echo '>>>export OPENDM_TTY="tty1"'
+ echo '>>>if [ -f "$HOME/.config/opendm/.opendmstart" ]; then'
+ echo '>>> . ~/.config/opendm/.opendmstart'
+ echo '>>>fi'
+} \ No newline at end of file