summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2017-10-20 17:24:56 +0300
committerAdrian Perez de Castro2017-10-20 17:24:56 +0300
commit7dd951c947fbc657883823461a9bd7b3f2926eda (patch)
tree6780291df4f472c0eefdcbf2244e69a0315cae72
downloadaur-7dd951c947fbc657883823461a9bd7b3f2926eda.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD25
-rw-r--r--opendoas.install10
4 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..44883589f508
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = opendoas
+ pkgdesc = Run commands as super user or another user, alternative to sudo
+ pkgver = 6.0
+ pkgrel = 1
+ url = https://github.com/Duncaen/OpenDoas
+ install = opendoas.install
+ arch = x86_64
+ arch = i686
+ license = custom:ISC
+ depends = pam
+ conflicts = opendoas-git
+ source = https://github.com/Duncaen/OpenDoas/archive/v6.0.tar.gz
+ sha512sums = 2bf5e00895a45d87785e7a494a1506844afd843ef5375e0b0e3795ebc24712bb941c6feeb87e426e41a240d40aca9b4c099f77220745bb7142a7a4b303441f60
+
+pkgname = opendoas
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..598bce3d9096
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+/*.tar
+/*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aecae88c4ee5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Adrián Pérez de Castro <aperez@igalia.com>
+pkgname='opendoas'
+pkgver='6.0'
+pkgrel='1'
+pkgdesc='Run commands as super user or another user, alternative to sudo'
+arch=('x86_64' 'i686')
+url="https://github.com/Duncaen/OpenDoas"
+license=('custom:ISC')
+depends=('pam')
+conflicts=('opendoas-git')
+install=opendoas.install
+source=("${url}/archive/v${pkgver}.tar.gz")
+sha512sums=('2bf5e00895a45d87785e7a494a1506844afd843ef5375e0b0e3795ebc24712bb941c6feeb87e426e41a240d40aca9b4c099f77220745bb7142a7a4b303441f60')
+
+build() {
+ cd "OpenDoas-${pkgver}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "OpenDoas-${pkgver}"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/opendoas.install b/opendoas.install
new file mode 100644
index 000000000000..7c0c335b457a
--- /dev/null
+++ b/opendoas.install
@@ -0,0 +1,10 @@
+post_install() {
+ cat <<-EOF
+ To allow members of the wheel group to run commands as other users, create the
+ file /etc/doas.conf with the following content:
+
+ permit :wheel
+
+ Refer to doas(1) and doas.conf(5) for more information.
+ EOF
+}