summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2013-10-31 02:02:02 +0100
committerCarsten Teibes2013-10-31 02:02:02 +0100
commit94c8e614e745c3c7017b148f5c6f928eda18b07b (patch)
tree3481080927521c0bd499b4b9838fb8d684e73936
downloadaur-94c8e614e745c3c7017b148f5c6f928eda18b07b.tar.gz
[add] opendune-git
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD59
-rw-r--r--opendune.desktop8
-rw-r--r--opendune.install16
-rw-r--r--opendune.pngbin0 -> 1841 bytes
-rw-r--r--opendune.sh25
6 files changed, 141 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..327e8100d5b6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = opendune-git
+ pkgdesc = Open source re-creation of the popular game Dune II
+ pkgver = 0.7.6615ef9
+ pkgrel = 1
+ url = https://github.com/OpenDUNE/OpenDUNE
+ install = opendune.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = sdl
+ depends = alsa-lib
+ optdepends = timidity++: midi music support
+ provides = opendune
+ conflicts = opendune
+ source = git://github.com/OpenDUNE/OpenDUNE.git
+ source = opendune.sh
+ source = opendune.desktop
+ source = opendune.png
+ source = opendune.install
+ md5sums = SKIP
+ md5sums = acaaaca7340f9b5d8c1d7ccc001ddf57
+ md5sums = 2ff96b1efe864b1426f950005625af35
+ md5sums = 4a6fef6e5bdde8ee7f038554bc5ed93b
+ md5sums = c997170cd2667920a5988a22b4b1e40f
+ sha256sums = SKIP
+ sha256sums = a62b0f37084654f3524ca4502c3864f90ef199e01755f5f18f162fa348f2fd2e
+ sha256sums = f2a41122e61587bb07528764fda1fb116ed00d41bab49d324bdc893607c3c029
+ sha256sums = 89c9cbf76b3f7ac62bf39235a64b191ee4b3bd437f88161b6757b6ec44e8888b
+ sha256sums = b672aca4ac3bc7d6f4578f2793c02dda5903e4d7cfc8b52a3e3ddc51bfe2816a
+
+pkgname = opendune-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f68a7241f51
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: carstene1ns <arch carsten-teibes de>
+
+_pkgbase=opendune
+pkgname=$_pkgbase-git
+_gitname=OpenDUNE
+pkgver=0.7.6615ef9
+pkgrel=1
+pkgdesc="Open source re-creation of the popular game Dune II"
+arch=('i686' 'x86_64')
+url="https://github.com/OpenDUNE/OpenDUNE"
+license=('GPL2')
+depends=('sdl' 'alsa-lib')
+makedepends=('git')
+optdepends=('timidity++: midi music support')
+conflicts=('opendune')
+provides=('opendune')
+install="$_pkgbase.install"
+source=("git://github.com/OpenDUNE/OpenDUNE.git"
+ "$_pkgbase.sh"
+ "$_pkgbase.desktop"
+ "$_pkgbase.png"
+ "$_pkgbase.install")
+md5sums=('SKIP'
+ 'acaaaca7340f9b5d8c1d7ccc001ddf57'
+ '2ff96b1efe864b1426f950005625af35'
+ '4a6fef6e5bdde8ee7f038554bc5ed93b'
+ 'c997170cd2667920a5988a22b4b1e40f')
+sha256sums=('SKIP'
+ 'a62b0f37084654f3524ca4502c3864f90ef199e01755f5f18f162fa348f2fd2e'
+ 'f2a41122e61587bb07528764fda1fb116ed00d41bab49d324bdc893607c3c029'
+ '89c9cbf76b3f7ac62bf39235a64b191ee4b3bd437f88161b6757b6ec44e8888b'
+ 'b672aca4ac3bc7d6f4578f2793c02dda5903e4d7cfc8b52a3e3ddc51bfe2816a')
+
+pkgver() {
+ cd $_gitname
+
+ # get last annotated tag from packed refs
+ echo $(tail -n 2 .git/packed-refs | head -n 1 | cut -d "/" -f 3).$(git rev-parse --short master)
+}
+
+build() {
+ cd $_gitname
+
+ ./configure --prefix-dir=/opt/opendune
+
+ make
+}
+
+package() {
+ cd $_gitname
+
+ make INSTALL_ICON_DIR="$pkgdir/opt/$_pkgbase" INSTALL_BINARY_DIR="$pkgdir/opt/$_pkgbase" INSTALL_DOC_DIR="$pkgdir/opt/$_pkgbase/doc" install
+
+ # install binary, icon and desktop files
+ install -Dm755 "$srcdir/$_pkgbase.sh" "$pkgdir/usr/bin/$_pkgbase"
+ install -Dm644 "$srcdir/$_gitname/bin/data/put_dune2_here.txt" "$pkgdir/opt/$_pkgbase/data/put_dune2_here.txt"
+ install -Dm644 "$srcdir/$_pkgbase.png" "$pkgdir/usr/share/pixmaps/$_pkgbase.png"
+ install -Dm644 "$srcdir/$_pkgbase.desktop" "$pkgdir/usr/share/applications/$_pkgbase.desktop"
+}
diff --git a/opendune.desktop b/opendune.desktop
new file mode 100644
index 000000000000..d9992938615a
--- /dev/null
+++ b/opendune.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=OpenDUNE
+Exec=opendune
+Icon=opendune
+Type=Application
+Comment=Open source re-creation of the popular game "Dune II"
+Categories=Game;
+Terminal=false
diff --git a/opendune.install b/opendune.install
new file mode 100644
index 000000000000..9edaaaee1210
--- /dev/null
+++ b/opendune.install
@@ -0,0 +1,16 @@
+
+post_install() {
+ # updates for our .desktop file
+ update-desktop-database -q
+
+ echo "Remember you need to be in the audio group and start timidity, eg 'timidity -iA' for music support."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ # updates for our .desktop file
+ update-desktop-database -q
+}
diff --git a/opendune.png b/opendune.png
new file mode 100644
index 000000000000..ce2adb7174af
--- /dev/null
+++ b/opendune.png
Binary files differ
diff --git a/opendune.sh b/opendune.sh
new file mode 100644
index 000000000000..060e5271b2f1
--- /dev/null
+++ b/opendune.sh
@@ -0,0 +1,25 @@
+#!/bin/sh
+#
+# OpenDUNE launcher // carstene1ns 2013
+#
+# Does some juggling with the data files and path
+
+[ ! -d $HOME/.opendune/data ] && mkdir -p $HOME/.opendune/data
+
+if [ ! -f $HOME/.opendune/data/put_dune2_here.cfg ]; then
+
+ cp /opt/opendune/data/put_dune2_here.txt $HOME/.opendune/data/
+
+fi
+
+if [ -f $HOME/.opendune/data/dune.pak ]; then
+
+ cd $HOME/.opendune
+ /opt/opendune/opendune "$@"
+ cd - &>/dev/null
+
+else
+
+ echo "Please place Dune II data files in \"$HOME/.opendune/data\"."
+
+fi