summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlfredo Beaumont2015-08-17 23:03:53 +0200
committerAlfredo Beaumont2015-08-17 23:03:53 +0200
commit042d728c186f15d9437e0565342465462ecf9cb6 (patch)
treeab8a0bfcf73b56d475f5448225ea6b7c7d97a6da
downloadaur-042d728c186f15d9437e0565342465462ecf9cb6.tar.gz
OpenDylan 2014.1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD35
-rw-r--r--opendylan.install15
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cf490015d21d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = opendylan
+ pkgdesc = Dylan is an advanced, object-oriented, dynamic language which supports rapid program development.
+ pkgver = 2014.1
+ pkgrel = 1
+ url = http://www.opendylan.org
+ install = opendylan.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ options = !strip
+ options = staticlibs
+
+pkgname = opendylan
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d75ab9d51eaa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Contributor: manveru <m.fellinger@gmail.com>
+# Contributor: Florian Richter <Florian_Richter@gmx.de>
+# Contributor: b4283
+# Maintainer: Alfredo Beaumont <alfredo.beaumont@gmail.com>
+
+pkgname=opendylan
+pkgver=2014.1
+pkgrel=1
+pkgdesc="Dylan is an advanced, object-oriented, dynamic language which supports rapid program development."
+arch=(i686 x86_64)
+url="http://www.opendylan.org"
+license=('custom')
+install=opendylan.install
+options=(!strip staticlibs)
+
+if [[ $CARCH == "i686" ]]; then
+ depends=('glibc')
+ source=(http://opendylan.org/downloads/$pkgname/$pkgver/$pkgname-$pkgver-x86-linux.tar.bz2)
+ md5sums=('8ed5e060f052710e99cef466a02c7a80')
+elif [[ $CARCH == "x86_64" ]]; then
+ depends=('glibc' 'gc')
+ source=(http://opendylan.org/downloads/$pkgname/$pkgver/$pkgname-$pkgver-x86_64-linux.tar.bz2)
+ md5sums=('8e8388f0a6e5d2b0411d7561977d733e')
+fi
+
+package() {
+ mkdir -p $pkgdir/usr/bin
+ mkdir -p $pkgdir/opt/$pkgname
+ cp -r $srcdir/$pkgname-$pkgver/{bin,databases,lib,sources,share} $pkgdir/opt/$pkgname
+ ln -sf /opt/$pkgname/bin/{dswank,dylan-compiler,make-dylan-app,parser-compiler} $pkgdir/usr/bin/$1
+ if [[ $CARCH = "x86_64" ]]; then
+ cp -r $srcdir/$pkgname-$pkgver/include $pkgdir/opt/$pkgname
+ fi
+ install -D -m644 $srcdir/$pkgname-$pkgver/License.txt $pkgdir/usr/share/licenses/$pkgname/License.txt
+}
diff --git a/opendylan.install b/opendylan.install
new file mode 100644
index 000000000000..4174733da68e
--- /dev/null
+++ b/opendylan.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo "/opt/opendylan/lib" >> /etc/ld.so.conf.d/opendylan.conf
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ rm /etc/ld.so.conf.d/opendylan.conf
+}
+
+op=$1
+shift
+$op $*