summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrontier2015-06-09 09:12:12 +0300
committerFrontier2015-06-09 09:12:12 +0300
commit342ffecc059ea72861b7ebb49569090b5515406d (patch)
tree804132bd0801269835773a30c0b6547e6d4e8c8f
downloadaur-342ffecc059ea72861b7ebb49569090b5515406d.tar.gz
Initial import to aur4
-rw-r--r--.SRCINFO17
-rwxr-xr-xPKGBUILD70
2 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3d173c73b5c7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = openeuphoria
+ pkgdesc = Fast interpreted or compiled general purpose programming language.
+ pkgver = 4.1.0
+ pkgrel = 2
+ url = http://openeuphoria.org
+ arch = i686
+ arch = x86_64
+ license = custom:"OpenEuphoria License"
+ conflicts = euphoria
+ options = staticlibs
+ source_i686 = http://sourceforge.net/projects/rapideuphoria/files/Euphoria/4.1.0-beta2/euphoria-4.1.0-Linux-x86-57179171dbed.tar.gz/download
+ md5sums_i686 = 6264506b48d135c19fa85ecc44fb305b
+ source_x86_64 = http://sourceforge.net/projects/rapideuphoria/files/Euphoria/4.1.0-beta2/euphoria-4.1.0-Linux-x64-57179171dbed.tar.gz/download
+ md5sums_x86_64 = a19ac9fcbe92c4916e4af3499a0af6f8
+
+pkgname = openeuphoria
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..1c764851c3cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,70 @@
+# Maintainer: Manos S. Pappas <gmail.com: frontier314>
+# Greetings to ktamp
+
+pkgname=openeuphoria
+pkgver=4.1.0
+pkgrel=2
+pkgdesc="Fast interpreted or compiled general purpose programming language."
+url="http://openeuphoria.org"
+license=('custom:"OpenEuphoria License"')
+conflicts=('euphoria')
+arch=('i686' 'x86_64')
+options=('staticlibs')
+source_x86_64=(http://sourceforge.net/projects/rapideuphoria/files/Euphoria/4.1.0-beta2/euphoria-${pkgver}-Linux-x64-57179171dbed.tar.gz/download)
+source_i686=(http://sourceforge.net/projects/rapideuphoria/files/Euphoria/4.1.0-beta2/euphoria-${pkgver}-Linux-x86-57179171dbed.tar.gz/download)
+md5sums_x86_64=('a19ac9fcbe92c4916e4af3499a0af6f8')
+md5sums_i686=('6264506b48d135c19fa85ecc44fb305b')
+
+build() {
+ cd ${srcdir}/euphoria-$pkgver*/
+}
+
+package() {
+ cd ${srcdir}/euphoria-${pkgver}*
+
+ mkdir -p "${pkgdir}/usr/share/${pkgname}/"
+ cp -r bin demo docs include source tests "${pkgdir}/usr/share/${pkgname}/"
+
+ # Make an initial eu.cfg
+if [ "$CARCH" = "x86_64" ]; then
+ cat > eu.cfg <<EOF
+[all]
+-d E64
+-eudir /usr/share/${pkgname}
+-i /usr/share/${pkgname}/include
+[translate]
+-arch ix86_64
+-gcc
+-con
+-com /usr/share/${pkgname}
+-lib-pic /usr/share/${pkgname}/bin/euso.a
+-lib /usr/share/${pkgname}/bin/eu.a
+[bind]
+-eub /usr/share/${pkgname}/bin/eub
+EOF
+fi
+
+if [ "$CARCH" = "i686" ]; then
+ cat > eu.cfg <<EOF
+[all]
+-d E32
+-eudir /usr/share/${pkgname}
+-i /usr/share/${pkgname}/include
+[translate]
+-arch ix86
+-gcc
+-con
+-com /usr/share/${pkgname}
+-lib-pic /usr/share/${pkgname}/bin/euso.a
+-lib /usr/share/${pkgname}/bin/eu.a
+[bind]
+-eub /usr/share/${pkgname}/bin/eub
+EOF
+fi
+
+ install -D -m644 eu.cfg "${pkgdir}/usr/share/${pkgname}/bin/eu.cfg"
+ install -D -m644 License.txt "${pkgdir}/usr/share/licenses/${pkgname}/License.txt"
+
+ echo "NOTE: Remember to add /usr/share/${pkgname}/bin/ to your PATH"
+}
+