summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2021-06-19 08:25:02 +0200
committerbartus2021-06-19 08:25:02 +0200
commit9680b9359eae0ea65c8b7711ad5469f029874b12 (patch)
tree921869ef35801b1adb625a052c80b8b08dc2437a
parent33125cdc2412d1d06ee82063d5e48ab177cf7b40 (diff)
downloadaur-9680b9359eae0ea65c8b7711ad5469f029874b12.tar.gz
Refactor, fix shellcheck warings
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e947c7491806..9f92922f7f5b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@ makedepends=('cmake' 'patchelf' 'python' 'boost' 'freeglut' 'python-numpy' 'chrp
optdepends=('boost-libs: python support' 'python: python support')
conflicts=('openexr')
provides=("openexr=${pkgver}")
-source=($pkgname-$pkgver.tar.gz::"https://github.com/openexr/openexr/archive/v$pkgver.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/openexr/openexr/archive/v$pkgver.tar.gz")
sha256sums=('59e98361cb31456a9634378d0f653a2b9554b8900f233450f2396ff495ea76b3')
build() {
@@ -26,7 +26,7 @@ package() {
install -D -m644 ${pkgname%2}-$pkgver/LICENSE.md -t "${pkgdir}/usr/share/licenses/${pkgname}"
# Install missing python module
- _pythonpath=`python -c "from sysconfig import get_path; print(get_path('platlib'))"`
- install -Dm755 build/python3*/imathnumpy.so -t "$pkgdir"/$_pythonpath
- patchelf --remove-rpath "${pkgdir}"/$_pythonpath/imathnumpy.so
+ _pythonpath=$(python -c "from sysconfig import get_path; print(get_path('platlib'))")
+ install -Dm755 build/python3*/imathnumpy.so -t "$pkgdir/$_pythonpath"
+ patchelf --set-rpath "" "${pkgdir}/$_pythonpath"/imathnumpy.so
}