summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2021-05-01 09:38:14 +0200
committerbartus2021-05-01 09:43:01 +0200
commitf5ebb30f8bc2d056289520499ac8d7b813450f90 (patch)
treeeb64159dccb7f9326554428cd842a667240c346e
downloadaur-f5ebb30f8bc2d056289520499ac8d7b813450f90.tar.gz
Init
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD31
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9244f05180de
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = openexr
+ pkgdesc = An high dynamic-range image file format library
+ pkgver = 2.5.5
+ pkgrel = 1
+ url = https://www.openexr.com/
+ arch = x86_64
+ license = BSD
+ makedepends = cmake
+ makedepends = python
+ makedepends = boost
+ makedepends = freeglut
+ makedepends = python-numpy
+ makedepends = chrpath
+ depends = zlib
+ optdepends = boost-libs: python support
+ optdepends = python: python support
+ conflicts = ilmbase
+ replaces = ilmbase
+ source = openexr-2.5.5.tar.gz::https://github.com/openexr/openexr/archive/v2.5.5.tar.gz
+ sha256sums = 59e98361cb31456a9634378d0f653a2b9554b8900f233450f2396ff495ea76b3
+
+pkgname = openexr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d0c7cc7ee127
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
+
+pkgname=openexr
+pkgver=2.5.5
+pkgrel=1
+pkgdesc="An high dynamic-range image file format library"
+url="https://www.openexr.com/"
+arch=('x86_64')
+license=('BSD')
+depends=('zlib')
+makedepends=('cmake' 'python' 'boost' 'freeglut' 'python-numpy' 'chrpath')
+optdepends=('boost-libs: python support' 'python: python support')
+conflicts=('ilmbase')
+replaces=('ilmbase')
+source=($pkgname-$pkgver.tar.gz::"https://github.com/openexr/openexr/archive/v$pkgver.tar.gz")
+sha256sums=('59e98361cb31456a9634378d0f653a2b9554b8900f233450f2396ff495ea76b3')
+
+build() {
+ cmake -B build -S $pkgname-$pkgver \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ cmake --build build
+}
+
+package() {
+ DESTDIR="${pkgdir}" cmake --install build
+ install -D -m644 $pkgname-$pkgver/LICENSE.md -t "${pkgdir}/usr/share/licenses/${pkgname}"
+
+# Install missing python module
+ _pythonpath=`python -c "from sysconfig import get_path; print(get_path('platlib'))"`
+ install -Dm755 build/python3*/imathnumpy.so -t "$pkgdir"/$_pythonpath
+}