summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Sferrazza2017-10-16 21:29:24 -0400
committerKyle Sferrazza2017-10-16 21:29:24 -0400
commit4cf771a38b21b67e610e535b4282c80080dd7c90 (patch)
tree6a0707649fe2b29ff54ea8d7eeac6bcbe795d000
downloadaur-4cf771a38b21b67e610e535b4282c80080dd7c90.tar.gz
Initial commit
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD44
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..33477fb68068
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = openface-git
+ pkgdesc = Face recognition with deep neural networks.
+ pkgver = ac4ded4
+ pkgrel = 1
+ url = http://cmusatyalab.github.io/openface/
+ arch = x86_64
+ license = Apache
+ depends = graphicsmagick
+ depends = openssl
+ depends = libffi
+ depends = python
+ depends = python-pip
+ depends = python-numpy
+ depends = python-nose
+ depends = python-scipy
+ depends = python-pandas
+ depends = python-protobuf
+ depends = python-sslib
+ depends = wget
+ depends = zip
+ provides = openface
+ conflicts = openface
+ source = openface::git+https://github.com/cmusatyalab/openface
+ md5sums = SKIP
+
+pkgname = openface-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c28a1b140f10
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.xz
+pkg
+src
+openface
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d05f57d0032f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Kyle Sferrazza <kyle.sferrazza@gmail.com>
+
+pkgname='openface-git'
+_pkgname='openface'
+pkgver="ac4ded4"
+pkgrel=1
+pkgdesc="Face recognition with deep neural networks."
+arch=('x86_64')
+url="http://cmusatyalab.github.io/openface/"
+license=("Apache")
+depends=("graphicsmagick"
+ "openssl"
+ "libffi"
+ "python"
+ "python-pip"
+ "python-numpy"
+ "python-nose"
+ "python-scipy"
+ "python-pandas"
+ "python-protobuf"
+ "python-sslib"
+ "wget"
+ "zip")
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=($_pkgname::"git+https://github.com/cmusatyalab/openface")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git rev-parse HEAD | cut -c 1-7
+}
+
+build() {
+ cd $_pkgname
+ ./models/get-models.sh
+
+ mkdir -p build
+ python2 setup.py install --root="$srcdir/$_pkgname/build/"
+}
+
+package() {
+ cp -r $srcdir/$_pkgname/build/usr $pkgdir
+}