summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlan Witkowski2015-06-08 10:24:07 -0600
committerAlan Witkowski2015-06-08 10:24:07 -0600
commit9197d004f8c4334efe7c9023f40999502649c6e4 (patch)
treee0c6ad068f9840ae73af283db28d92e53f4d8e01
downloadaur-9197d004f8c4334efe7c9023f40999502649c6e4.tar.gz
initial import
-rw-r--r--.SRCINFO19
-rw-r--r--Changelog6
-rw-r--r--PKGBUILD31
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9e7267d30ffb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = openflap
+ pkgdesc = A game about bouncing balls through holes
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/jazztickets/openflap
+ changelog = Changelog
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ depends = sdl2
+ depends = sdl2_image
+ depends = sdl2_ttf
+ depends = sdl2_mixer
+ source = https://github.com/jazztickets/openflap/archive/1.0.tar.gz
+ sha256sums = aca8ed0fe0e8229ee26344e01bb4b7a69877bf4cfe96bab991770f5048ab0ff9
+
+pkgname = openflap
+
diff --git a/Changelog b/Changelog
new file mode 100644
index 000000000000..6b4964c32220
--- /dev/null
+++ b/Changelog
@@ -0,0 +1,6 @@
+2014-03-10 Alan Witkowski <alan.witkowski@gmail.com>
+
+ 1.0-1:
+ * First release
+
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..07621e85e494
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Alan Witkowski <alan dot witkowski at gmail dot com>
+pkgname=openflap
+pkgver=1.0
+pkgrel=1
+pkgdesc="A game about bouncing balls through holes"
+arch=('i686' 'x86_64')
+url="https://github.com/jazztickets/openflap"
+license=('GPL3')
+depends=('sdl2' 'sdl2_image' 'sdl2_ttf' 'sdl2_mixer')
+makedepends=('cmake')
+changelog=Changelog
+source=("https://github.com/jazztickets/openflap/archive/$pkgver.tar.gz")
+sha256sums=('aca8ed0fe0e8229ee26344e01bb4b7a69877bf4cfe96bab991770f5048ab0ff9')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+
+ # remove standard license
+ rm $pkgdir/usr/share/doc/$pkgname/LICENSE
+}