summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJingbei Li2018-07-20 10:50:35 +0800
committerJingbei Li2018-07-20 10:50:35 +0800
commite2213a17037e29064ceb3076164950a11d57c8ee (patch)
treef3311103ce59bd29562a5f7151ec04cf4953a3e9
parent07b776587cbea3cc21911a2353188779656b8dc1 (diff)
downloadaur-e2213a17037e29064ceb3076164950a11d57c8ee.tar.gz
upgraded to 6
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD23
2 files changed, 17 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aab2fe020c5f..5fdd7b754c60 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openfoam
pkgdesc = The open source CFD toolbox
- pkgver = 5.0
- pkgrel = 3
+ pkgver = 6
+ pkgrel = 1
url = http://www.openfoam.org
install = openfoam.install
arch = x86_64
@@ -14,8 +14,10 @@ pkgbase = openfoam
depends = boost
depends = flex
depends = cgal
- source = https://github.com/OpenFOAM/OpenFOAM-5.x/archive/version-5.0.tar.gz
- md5sums = cd8c5bdd3ff39c34f61747c8e55f59d1
+ source = https://github.com/OpenFOAM/OpenFOAM-6/archive/version-6.tar.gz
+ source = openfoam.install
+ md5sums = f40aa39d4d5dfe7ea8d9a58f2625037a
+ md5sums = 906a97732076501f3899d72d3a7393b3
pkgname = openfoam
diff --git a/PKGBUILD b/PKGBUILD
index 4942f3cad83c..0ced6c3d2d06 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,20 @@
# Contributor: George Eleftheriou <eleftg>
# Contributor: Andrew Fischer <andrew_at_apastron.co>
-# The distributors package name
-_distpkgname=OpenFOAM
-_gitname=$_distpkgname-5.x
-
pkgname=openfoam
-pkgver=5.0
-pkgrel=3
+pkgver=6
+pkgrel=1
pkgdesc="The open source CFD toolbox"
+_distpkgname=OpenFOAM
+_gitname=$_distpkgname-$pkgver
arch=('x86_64')
url="http://www.openfoam.org"
license=("GPL")
depends=('bzip2' 'paraview' 'parmetis' 'scotch' 'boost' 'flex' 'cgal')
makedepends=('bash')
-source=("https://github.com/OpenFOAM/$_gitname/archive/version-$pkgver.tar.gz")
+source=("https://github.com/OpenFOAM/$_gitname/archive/version-$pkgver.tar.gz" "${pkgname}.install")
install="${pkgname}.install"
-md5sums=('cd8c5bdd3ff39c34f61747c8e55f59d1')
+md5sums=('f40aa39d4d5dfe7ea8d9a58f2625037a' '906a97732076501f3899d72d3a7393b3')
prepare() {
mv $srcdir/$_gitname-version-$pkgver $srcdir/$_distpkgname-$pkgver
@@ -39,6 +37,11 @@ prepare() {
echo "export SCOTCH_VERSION=scotch_${_sversion}" > ${srcdir}/scotch.sh
echo "export SCOTCH_ARCH_PATH=/usr" >> ${srcdir}/scotch.sh
cp ${srcdir}/scotch.sh ${srcdir}/${_distpkgname}-${pkgver}/etc/config #|| return 1
+
+ # Patches
+ #cd ${srcdir}/${_distpkgname}-${pkgver}
+ #sed '550s| \*this||' -i src/OpenFOAM/containers/Lists/PackedList/PackedListI.H
+ #sed '35,40d' -i src/thermophysicalModels/specie/reaction/Reactions/Reaction/ReactionI.H
}
build() {
@@ -50,10 +53,6 @@ build() {
# Enter build directory
cd ${srcdir}/${_distpkgname}-${pkgver}
- # Patches
- sed '550s| \*this||' -i src/OpenFOAM/containers/Lists/PackedList/PackedListI.H
- sed '35,40d' -i src/thermophysicalModels/specie/reaction/Reactions/Reaction/ReactionI.H
-
# Build and clean up OpenFOAM
bash -c "source ${foamDotFile}
./Allwmake || exit 1