summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharles DELFLY2018-01-04 02:14:43 +0700
committerCharles DELFLY2018-01-04 02:14:43 +0700
commit0a00fcf85640ec679a2a42d16e0b2b5d8e802749 (patch)
tree601fcd051d194823a9baeafecc51229d2d5aa992
downloadaur-0a00fcf85640ec679a2a42d16e0b2b5d8e802749.tar.gz
Create initial PKGBUILD
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD53
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..76b78e7ad1eb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = openfortigui
+ pkgdesc = OpenFortiGUI is an open-source VPN-Client to connect to Fortigate VPN-Hardware. It is based on openfortivpn and adds an easy to use and nice GUI on top of it, written in Qt5.
+ pkgver = 0.4.1
+ pkgrel = 1
+ url = https://github.com/theinvisible/openfortigui.git
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = qt5-base
+ depends = openssl
+ depends = ppp
+ depends = sudo
+ source = git+https://github.com/theinvisible/openfortigui.git#tag=v0.4.1
+ md5sums = SKIP
+
+pkgname = openfortigui
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d0e03c3f8992
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Charles Delfly <charles@delfly.fr>
+pkgname=openfortigui
+pkgver=0.4.1
+pkgrel=1
+pkgdesc="OpenFortiGUI is an open-source VPN-Client to connect to Fortigate VPN-Hardware. It is based on openfortivpn and adds an easy to use and nice GUI on top of it, written in Qt5."
+arch=('i686' 'x86_64')
+url="https://github.com/theinvisible/openfortigui.git"
+license=('GPL3')
+groups=()
+depends=('qt5-base' 'openssl' 'ppp' 'sudo')
+makedepends=('git') # 'bzr', 'git', 'mercurial' or 'subversion'
+provides=()
+conflicts=()
+replaces=()
+options=()
+install=
+source=("git+https://github.com/theinvisible/$pkgname.git#tag=v$pkgver")
+noextract=()
+md5sums=('SKIP')
+
+prepare() {
+ cd "$srcdir/$pkgname"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ cd openfortigui
+ git submodule init
+ git submodule update
+ cd qtinyaes
+ git submodule init
+ git submodule update
+ cd ../..
+ qmake
+ make -j8
+}
+
+
+check() {
+ cd "$srcdir/$pkgname"
+ make -k check
+}
+
+package() {
+ cd "$srcdir/$pkgname/openfortigui"
+ mkdir -p $pkgdir/usr/bin $pkgdir/usr/share/pixmaps $pkgdir/usr/share/applications $pkgdir/etc/sudoers.d $pkgdir/etc/openfortigui/vpnprofiles
+ install -m 755 openfortigui $pkgdir/usr/bin/
+ install -m 440 sudo/openfortigui $pkgdir/etc/sudoers.d
+ install -m 644 app-entry/openfortigui.png $pkgdir/usr/share/pixmaps/
+ install -m 644 app-entry/openfortigui.desktop $pkgdir/usr/share/applications/
+}
+
+