summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaciej Ɓotysz2017-05-19 15:30:14 +0200
committerPatrick Hanft2017-05-20 14:46:30 +0200
commit14408c345797163ad637b0884f84d81761759982 (patch)
treeb04ccbbfc4a483aea06bbc888576ab9d516aac33
parent96a924eef321c8e8994c625f5955f27808474435 (diff)
downloadaur-14408c345797163ad637b0884f84d81761759982.tar.gz
Fix building error - workaround
https://github.com/adrienverge/openfortivpn/issues/81
-rw-r--r--PKGBUILD10
-rw-r--r--allow-no-unused-functions.patch11
2 files changed, 19 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5dbbb114afa5..f8985aff689d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,9 +15,15 @@ replaces=()
backup=('etc/openfortivpn/config')
options=()
install=
-source=("git+https://github.com/adrienverge/$pkgname.git#tag=v$pkgver")
+source=("git+https://github.com/adrienverge/$pkgname.git#tag=v$pkgver" "allow-no-unused-functions.patch")
noextract=()
-md5sums=('SKIP')
+md5sums=('SKIP'
+ '4ce932a43c5b6e7241fb3e7ccc7a199f')
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ patch -Np0 -i "${srcdir}/allow-no-unused-functions.patch"
+}
build() {
cd "$srcdir/$pkgname"
diff --git a/allow-no-unused-functions.patch b/allow-no-unused-functions.patch
new file mode 100644
index 000000000000..bc0a3fd3a5c1
--- /dev/null
+++ b/allow-no-unused-functions.patch
@@ -0,0 +1,11 @@
+--- Makefile.am 2017-05-19 15:17:40.131425922 +0200
++++ Makefile.am.new 2017-05-19 15:17:34.131583469 +0200
+@@ -6,7 +6,7 @@
+ src/ipv4.h src/log.c src/log.h src/tunnel.c \
+ src/tunnel.h src/main.c src/ssl.h src/xml.c \
+ src/xml.h src/userinput.c src/userinput.h
+-openfortivpn_CFLAGS = -Wall -Werror --pedantic -std=gnu99
++openfortivpn_CFLAGS = -Wall -Werror --pedantic -std=gnu99 -Wno-unused-function
+
+ confdir=$(sysconfdir)/openfortivpn
+ conf_DATA = etc/openfortivpn/config