summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Pompili2015-09-27 16:33:20 +0200
committerMarco Pompili2015-09-28 12:11:05 +0200
commit004d2f099ad85497b040083b6e8b5815495d97a7 (patch)
treefc1e28a22f9fa6a1905ce2e23186b4d6d6260db6
downloadaur-004d2f099ad85497b040083b6e8b5815495d97a7.tar.gz
Initial version 0.8.4
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD45
-rwxr-xr-xof-make-workspace34
-rw-r--r--openframeworks.install9
5 files changed, 117 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a466f29ce259
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = openframeworks
+ pkgdesc = openFrameworks is an open source C++ toolkit for creative coding.
+ pkgver = 0.8.4
+ pkgrel = 1
+ url = http://openframeworks.cc/
+ install = openframeworks.install
+ arch = x86_64
+ arch = i686
+ license = MIT
+ depends = cairo
+ depends = mpg123
+ depends = gst-plugins-ugly
+ depends = freeimage
+ depends = gst-libav
+ depends = python-lxml
+ optdepends = codeblocks
+ optdepends = xterm
+ source = http://www.openframeworks.cc/versions/v0.8.4/of_v0.8.4_linux64_release.tar.gz
+ source = of-make-workspace
+ md5sums = 8465ecdaf86a45f0e0f43443e98966fe
+ md5sums = 6a6111a7a98279498899ef0eba789589
+
+pkgname = openframeworks
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..06e3e8c456ce
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+of_v*
+openframeworks-*
+y
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..faa2d12057a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+pkgname=openframeworks
+pkgver=0.8.4
+pkgrel=1
+pkgdesc="openFrameworks is an open source C++ toolkit for creative coding."
+url="http://openframeworks.cc/"
+arch=('x86_64' 'i686')
+license='MIT'
+depends=('cairo' 'mpg123' 'gst-plugins-ugly' 'freeimage' 'gst-libav' 'python-lxml')
+optdepends=('codeblocks' 'xterm')
+makedepends=()
+install=openframeworks.install
+
+[[ "$CARCH" == "i686" ]] && _arch="linux" || _arch="linux64"
+_name=of_v${pkgver}_${_arch}_release
+
+source=("http://www.openframeworks.cc/versions/v${pkgver}/${_name}.tar.gz" "of-make-workspace")
+
+[[ "$CARCH" == "i686" ]] && md5sums=("ff38e469b8ebda0529c9d131bc4f499c") || md5sums=("8465ecdaf86a45f0e0f43443e98966fe")
+
+md5sums+=("6a6111a7a98279498899ef0eba789589")
+
+build() {
+ cd ${srcdir}/$_name/scripts/linux/
+
+ msg2 "Building openFrameworks..."
+ ./compileOF.sh > /dev/null
+
+ msg2 "Building the OF Project Generator..."
+ ./compilePG.sh > /dev/null
+}
+
+package() {
+ install -d -m755 "${pkgdir}/opt"
+
+ cp -R "${srcdir}/${_name}" "${pkgdir}/opt/openFrameworks"
+
+ install -D -m775 "${srcdir}/of-make-workspace" "${pkgdir}/usr/bin/of-make-workspace"
+
+ msg2 "Fixing emptyExample project files permissions..."
+
+ chmod 644 "${pkgdir}"/opt/openFrameworks/apps/myApps/emptyExample/config.make
+ chmod 644 "${pkgdir}"/opt/openFrameworks/apps/myApps/emptyExample/emptyExample.cbp
+ chmod 644 "${pkgdir}"/opt/openFrameworks/apps/myApps/emptyExample/emptyExample.workspace
+ chmod 644 "${pkgdir}"/opt/openFrameworks/apps/myApps/emptyExample/Makefile
+}
diff --git a/of-make-workspace b/of-make-workspace
new file mode 100755
index 000000000000..0a7a503d3e6f
--- /dev/null
+++ b/of-make-workspace
@@ -0,0 +1,34 @@
+#!/bin/bash
+
+echo -e "Initializing local workspace for openFrameworks..."
+
+WS=~/of-workspace
+
+mkdir -p $WS
+cd $WS
+
+cp -R /opt/openFrameworks/addons .
+
+mkdir -p apps/myApps
+
+cd apps
+
+cp -R /opt/openFrameworks/projectGenerator .
+
+cd myApps
+
+ln -s /opt/openFrameworks/apps/myApps/emptyExample
+
+cd ../..
+
+ln -s /opt/openFrameworks/CHANGELOG.md
+ln -s /opt/openFrameworks/docs
+ln -s /opt/openFrameworks/examples
+ln -s /opt/openFrameworks/export
+ln -s /opt/openFrameworks/INSTALL.md
+cp -R /opt/openFrameworks/libs .
+ln -s /opt/openFrameworks/LICENSE.md
+ln -s /opt/openFrameworks/other
+cp -R /opt/openFrameworks/projectGenerator .
+ln -s /opt/openFrameworks/README.md
+ln -s /opt/openFrameworks/scripts
diff --git a/openframeworks.install b/openframeworks.install
new file mode 100644
index 000000000000..732bc0d31a4a
--- /dev/null
+++ b/openframeworks.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo "The Project Generator is in /opt/openFrameworks/apps/projectGenerator/projectGeneratorSimple."
+ echo -e "To initialize the workspace needed for openFrameworks launching the command: \033[0;32mof-make-workspace\033[0m"
+ echo "this command will initialize a workspace folder in your home directory."
+}
+
+post_update() {
+ echo -e "Remeber to regenerate your local workspace using: \033[0;32mof-make-workspace\033[0m".
+}