summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJingbei Li2022-07-23 20:18:51 +0800
committerJingbei Li2022-07-23 21:27:14 +0800
commit0a8a54193d1583f025ea806b61c97d615a40e23a (patch)
tree287d2d2aa00d19e686a39007cf8a09386cc39e00
parent4427607529e41cd131ccfd96ef4751837dc2a8fe (diff)
downloadaur-0a8a54193d1583f025ea806b61c97d615a40e23a.tar.gz
upgraded to 1.8.2; disabled python
quite complex error
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD16
3 files changed, 16 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2fdf2222ccc3..838db0686057 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
pkgbase = openfst
pkgdesc = Library for constructing, combining, optimizing, and searching weighted finite-state transducers (FSTs)
- pkgver = 1.7.9
+ pkgver = 1.8.2
pkgrel = 1
- url = http://www.openfst.org
- arch = i686
+ url = https://www.openfst.org
arch = x86_64
license = Apache
depends = gcc-libs
depends = glibc
- depends = python
options = !libtool
- source = http://www.openfst.org/twiki/pub/FST/FstDownload/openfst-1.7.9.tar.gz
- sha256sums = 9319aeb31d1e2950ae25449884e255cc2bc9dfaf987f601590763e61a10fbdde
+ options = !lto
+ source = https://www.openfst.org/twiki/pub/FST/FstDownload/openfst-1.8.2.tar.gz
+ sha256sums = de987bf3624721c5d5ba321af95751898e4f4bb41c8a36e2d64f0627656d8b42
pkgname = openfst
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..147300718820
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*/
+*.log
+*.tar*
diff --git a/PKGBUILD b/PKGBUILD
index f85e4c8c2afe..ec4965ef712e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,16 +5,16 @@
# Contributor: Christoph Drexler <chrdr at gmx dot at>
pkgname=openfst
-pkgver=1.7.9
+pkgver=1.8.2
pkgrel=1
pkgdesc='Library for constructing, combining, optimizing, and searching weighted finite-state transducers (FSTs)'
-arch=(i686 x86_64)
-url='http://www.openfst.org'
+arch=(x86_64)
+url='https://www.openfst.org'
license=(Apache)
-depends=(gcc-libs glibc python)
-options=(!libtool)
-source=(http://www.openfst.org/twiki/pub/FST/FstDownload/$pkgname-$pkgver.tar.gz)
-sha256sums=(9319aeb31d1e2950ae25449884e255cc2bc9dfaf987f601590763e61a10fbdde)
+depends=(gcc-libs glibc)
+options=(!libtool !lto)
+source=("${url}/twiki/pub/FST/FstDownload/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('de987bf3624721c5d5ba321af95751898e4f4bb41c8a36e2d64f0627656d8b42')
build() {
cd $srcdir/$pkgname-$pkgver
@@ -31,7 +31,7 @@ build() {
OPTIONS+=' --enable-mpdt' # Enable MPDT extensions; Default: no
OPTIONS+=' --enable-ngram-fsts' # Enable NGramFst extensions; Default: no
OPTIONS+=' --enable-pdt' # Enable PDT extensions; Default: no
- OPTIONS+=' --enable-python PYTHON=python' # Enable Python extensions; Default: no
+ #OPTIONS+=' --enable-python PYTHON=python' # Enable Python extensions; Default: no
LIBS='-ldl' ./configure $OPTIONS
make