summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbuggs2015-07-30 20:53:06 +0200
committerbuggs2015-07-30 20:53:06 +0200
commit4171df2b5e1eb47de0331aa8e2b7c4f6c5a49af9 (patch)
tree3db64a6cf266b8a9c33c8935752fe66988ca4c10
parent66a8bb1ad0f3d191be4c937ebf18fe469e809b2f (diff)
downloadaur-4171df2b5e1eb47de0331aa8e2b7c4f6c5a49af9.tar.gz
Add /usr/lib/fst to ld.so.conf and fix python option.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c995ca1cc9e..4cf41902dc29 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openfst
pkgdesc = Library for constructing, combining, optimizing, and searching weighted finite-state transducers (FSTs)
pkgver = 1.5.0
- pkgrel = 1
+ pkgrel = 2
url = http://www.openfst.org/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 7e982f6ff742..5d6d639bbd66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: Christoph Drexler <chrdr at gmx dot at>
+# Maintainer: Andreas Hauser <andy-aur@splashground.de>
+# Former Maintainer: Christoph Drexler <chrdr at gmx dot at>
pkgname=openfst
pkgver=1.5.0
-pkgrel=1
+pkgrel=2
pkgdesc="Library for constructing, combining, optimizing, and searching weighted finite-state transducers (FSTs)"
arch=('i686' 'x86_64')
url="http://www.openfst.org/"
@@ -28,7 +29,7 @@ build() {
OPTIONS+=" --enable-mpdt" # Enable MPDT extensions; Default: no
OPTIONS+=" --enable-ngram-fsts" # Enable NGramFst extensions; Default: no
OPTIONS+=" --enable-pdt" # Enable PDT extensions; Default: no
- OPTIONS+=" --enable-python" # Enable Python extensions; Default: no
+ OPTIONS+=" --enable-python PYTHON=python2" # Enable Python extensions; Default: no
LIBS="-ldl" ./configure $OPTIONS
make
}
@@ -36,4 +37,7 @@ build() {
package() {
cd ${srcdir}/${pkgname}-${pkgver}
make DESTDIR=${pkgdir} install
+
+ install -dm755 "$pkgdir"/etc/ld.so.conf.d/
+ echo '/usr/lib/fst' > "$pkgdir"/etc/ld.so.conf.d/openfst.conf
}