summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCheong Sik Feng2020-04-26 12:43:43 +0800
committerCheong Sik Feng2020-04-26 12:43:43 +0800
commit49d01c43e1a4c7bfb19fe3af5e6d71afc29e2e56 (patch)
tree222fcdc5f14244b75d888ecff09c3ccf360600b7
parentfc747ffb4c8387c7fd61cdc47ecb6d1cf196c072 (diff)
downloadaur-49d01c43e1a4c7bfb19fe3af5e6d71afc29e2e56.tar.gz
update to 1.7.6 using walwe's PKGBUILD
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d49b2d52d252..a3e99d8dc001 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sun Apr 1 08:04:36 UTC 2018
pkgbase = openfst
pkgdesc = Library for constructing, combining, optimizing, and searching weighted finite-state transducers (FSTs)
- pkgver = 1.6.7
+ pkgver = 1.7.6
pkgrel = 1
url = http://www.openfst.org
arch = i686
@@ -10,12 +8,10 @@ pkgbase = openfst
license = Apache
depends = gcc-libs
depends = glibc
- depends = python2
+ depends = python
options = !libtool
- source = http://www.openfst.org/twiki/pub/FST/FstDownload/openfst-1.6.7.tar.gz
- sha1sums = b6c2771c8deee6879a2c98a0c975b078f59c7dd7
- sha256sums = e21a486d827cde6a592c8e91721e4540ad01a5ae35a60423cf17be4d716017f7
- sha512sums = 1963de3c3c08d2d97c4702d0b8fa2c802dfb74280a3ec2b01a8c910c870b10b52fc5d591b05077f0c6bfc434de52baa76c7665ed957050921772af0adae908be
+ source = http://www.openfst.org/twiki/pub/FST/FstDownload/openfst-1.7.6.tar.gz
+ sha1sums = 3fb669b7c064c83f7768d9089b2914a782890474
pkgname = openfst
diff --git a/PKGBUILD b/PKGBUILD
index 54a34aa575dc..0b764f5fcb93 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,18 +4,16 @@
# Contributor: Christoph Drexler <chrdr at gmx dot at>
pkgname=openfst
-pkgver=1.6.7
+pkgver=1.7.6
pkgrel=1
pkgdesc='Library for constructing, combining, optimizing, and searching weighted finite-state transducers (FSTs)'
arch=(i686 x86_64)
url='http://www.openfst.org'
license=(Apache)
-depends=(gcc-libs glibc python2)
+depends=(gcc-libs glibc python)
options=(!libtool)
source=(http://www.openfst.org/twiki/pub/FST/FstDownload/$pkgname-$pkgver.tar.gz)
-sha1sums=(b6c2771c8deee6879a2c98a0c975b078f59c7dd7)
-sha256sums=(e21a486d827cde6a592c8e91721e4540ad01a5ae35a60423cf17be4d716017f7)
-sha512sums=(1963de3c3c08d2d97c4702d0b8fa2c802dfb74280a3ec2b01a8c910c870b10b52fc5d591b05077f0c6bfc434de52baa76c7665ed957050921772af0adae908be)
+sha1sums=(3fb669b7c064c83f7768d9089b2914a782890474)
build() {
cd $srcdir/$pkgname-$pkgver
@@ -32,8 +30,8 @@ build() {
OPTIONS+=' --enable-mpdt' # Enable MPDT extensions; Default: no
OPTIONS+=' --enable-ngram-fsts' # Enable NGramFst extensions; Default: no
OPTIONS+=' --enable-pdt' # Enable PDT extensions; Default: no
- OPTIONS+=' --enable-python PYTHON=python2' # Enable Python extensions; Default: no
- LIBS=-ldl ./configure $OPTIONS
+ OPTIONS+=' --enable-python PYTHON=python' # Enable Python extensions; Default: no
+ LIBS='-ldl' ./configure $OPTIONS
make
}