summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2017-06-16 06:04:29 -0400
committerJean Lucas2017-06-16 06:06:34 -0400
commita1649b822bd8c1150b2750733362e7da533a703d (patch)
treebc34fed61f719ee16db9e963937d91b86bd8f759
parentad179eecc93f4e958d868c35d960226ab9e03f3d (diff)
downloadaur-a1649b822bd8c1150b2750733362e7da533a703d.tar.gz
version bump to 1.6.2
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD57
2 files changed, 35 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bc7c7d7b6917..5366f4c37628 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
# Generated by mksrcinfo v8
-# Sat Oct 29 22:42:38 UTC 2016
+# Fri Jun 16 10:03:52 UTC 2017
pkgbase = openfst
pkgdesc = Library for constructing, combining, optimizing, and searching weighted finite-state transducers (FSTs)
- pkgver = 1.5.4.1
+ pkgver = 1.6.2
pkgrel = 1
- url = http://www.openfst.org/
+ url = http://www.openfst.org
arch = i686
arch = x86_64
- license = APACHE
+ license = Apache
depends = gcc-libs
depends = glibc
depends = python2
options = !libtool
- source = http://openfst.cs.nyu.edu/twiki/bin/viewfile/FST/FstDownload?filename=openfst-1.5.4.tar.gz;rev=1
- sha256sums = acc115aaaa33de53de62dae44120ab368fabaea06f52606b77714081ecd32657
+ source = http://www.openfst.org/twiki/pub/FST/FstDownload/openfst-1.6.2.tar.gz
+ sha256sums = 3f72e35097fdf1c1c41e15165c16696c223295b40b7b145b5466306db7972578
pkgname = openfst
diff --git a/PKGBUILD b/PKGBUILD
index d6164fdc2f1a..9fc541ed026b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,44 @@
-# Maintainer: Andreas Hauser <andy-aur@splashground.de>
-# Former Maintainer: Christoph Drexler <chrdr at gmx dot at>
+# Maintainer: Jean Lucas <jean@4ray.co>
+# Contributor: Kilian Gebhardt <gebhardtkilian at gmail dot com>
+# Contributor: Andreas Hauser <andy-aur@splashground.de>
+# Contributor: Christoph Drexler <chrdr at gmx dot at>
pkgname=openfst
-pkgver=1.5.4.1
+pkgver=1.6.2
pkgrel=1
pkgdesc="Library for constructing, combining, optimizing, and searching weighted finite-state transducers (FSTs)"
arch=('i686' 'x86_64')
-url="http://www.openfst.org/"
-license=('APACHE')
+url="http://www.openfst.org"
+license=('Apache')
depends=('gcc-libs' 'glibc' 'python2')
options=(!libtool)
-source=("http://openfst.cs.nyu.edu/twiki/bin/viewfile/FST/FstDownload?filename=${pkgname}-${pkgver/%.?/}.tar.gz;rev=${pkgver/*./}")
-sha256sums=('acc115aaaa33de53de62dae44120ab368fabaea06f52606b77714081ecd32657')
-
+source=("http://www.openfst.org/twiki/pub/FST/FstDownload/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('3f72e35097fdf1c1c41e15165c16696c223295b40b7b145b5466306db7972578')
build() {
- cd ${srcdir}/${pkgname}-${pkgver/%.?/}
+ cd "${srcdir}/${pkgname}-${pkgver}"
- # Options according to http://openfst.cs.nyu.edu/twiki/bin/view/FST/ReadMe
- OPTIONS="--prefix=/usr --disable-dependency-tracking"
- OPTIONS+=" --enable-bin" # Enable fst::script and command-line binaries; Default: yes
- OPTIONS+=" --enable-compact-fsts" # Enable all CompactFst classes; Default: no
- OPTIONS+=" --enable-compress" # Enable compression extension; Default: no
- OPTIONS+=" --enable-const-fsts" # Enable all ConstFst classes; Default: no
- OPTIONS+=" --enable-far" # Enable FAR (FST Archive) extension; Default: no
- OPTIONS+=" --enable-linear-fsts" # Enable Linear{Tagger,Classifier}Fst extensions; Default: no
- OPTIONS+=" --enable-lookahead-fsts" # Enable LookAheadFst classes; Default: no
- OPTIONS+=" --enable-mpdt" # Enable MPDT extensions; Default: no
- OPTIONS+=" --enable-ngram-fsts" # Enable NGramFst extensions; Default: no
- OPTIONS+=" --enable-pdt" # Enable PDT extensions; Default: no
- OPTIONS+=" --enable-python PYTHON=python2" # Enable Python extensions; Default: no
- LIBS="-ldl" ./configure $OPTIONS
- make
+ # Options according to http://openfst.cs.nyu.edu/twiki/bin/view/FST/ReadMe
+ OPTIONS="--prefix=/usr --disable-dependency-tracking"
+ OPTIONS+=" --enable-bin" # Enable fst::script and command-line binaries; Default: yes
+ OPTIONS+=" --enable-compact-fsts" # Enable all CompactFst classes; Default: no
+ OPTIONS+=" --enable-compress" # Enable compression extension; Default: no
+ OPTIONS+=" --enable-const-fsts" # Enable all ConstFst classes; Default: no
+ OPTIONS+=" --enable-far" # Enable FAR (FST Archive) extension; Default: no
+ OPTIONS+=" --enable-linear-fsts" # Enable Linear{Tagger,Classifier}Fst extensions; Default: no
+ OPTIONS+=" --enable-lookahead-fsts" # Enable LookAheadFst classes; Default: no
+ OPTIONS+=" --enable-mpdt" # Enable MPDT extensions; Default: no
+ OPTIONS+=" --enable-ngram-fsts" # Enable NGramFst extensions; Default: no
+ OPTIONS+=" --enable-pdt" # Enable PDT extensions; Default: no
+ OPTIONS+=" --enable-python PYTHON=python2" # Enable Python extensions; Default: no
+ LIBS="-ldl" ./configure $OPTIONS
+ make
}
package() {
- cd ${srcdir}/${pkgname}-${pkgver/%.?/}
- make DESTDIR=${pkgdir} install
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
- install -dm755 "$pkgdir"/etc/ld.so.conf.d/
- echo '/usr/lib/fst' > "$pkgdir"/etc/ld.so.conf.d/openfst.conf
+ install -d "${pkgdir}/etc/ld.so.conf.d/"
+ echo '/usr/lib/fst' > "${pkgdir}/etc/ld.so.conf.d/openfst.conf"
}