summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHugo Courtial2016-08-21 19:59:28 +0200
committerHugo Courtial2016-08-21 19:59:28 +0200
commit26a415d73ab1011f7fac85c7990cbd0add75c3ca (patch)
treebc40c1348ae79dba4bbe9e7d968113c6526a2ed0
downloadaur-26a415d73ab1011f7fac85c7990cbd0add75c3ca.tar.gz
First version of the package
-rw-r--r--.SRCINFO23
-rw-r--r--GCC6.patch138
-rw-r--r--PKGBUILD30
3 files changed, 191 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..33c384b4a37f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = openfx-arena
+ pkgdesc = Extra OpenFX plugins for Natron
+ pkgver = 2.1.2
+ pkgrel = 1
+ url = https://github.com/olear/openfx-arena/tree/Natron-2.1.2
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = gcc-libs-multilib
+ depends = imagemagick
+ depends = libcdr
+ depends = librsvg
+ depends = libtool
+ depends = libzip
+ depends = opencolorio
+ depends = poppler-glib
+ source = openfx-arena::git://github.com/olear/openfx-arena.git#tag=Natron-2.1.2
+ source = GCC6.patch
+ md5sums = SKIP
+ md5sums = 8da02f30c37861eaaac9245ff4cb005b
+
+pkgname = openfx-arena
+
diff --git a/GCC6.patch b/GCC6.patch
new file mode 100644
index 000000000000..f7046197a6f1
--- /dev/null
+++ b/GCC6.patch
@@ -0,0 +1,138 @@
+From 48241ff38192fd1310ec7ab6ac9179e0269ab1de Mon Sep 17 00:00:00 2001
+From: Hugo Courtial <hugo@courtial.me>
+Date: Sat, 20 Aug 2016 23:12:38 +0200
+Subject: [PATCH] GCC6 patches
+
+---
+ Support/Library/ofxsImageEffect.cpp | 32 ++++++++++++++++----------------
+ Support/Library/ofxsSupportPrivate.h | 12 ++++++------
+ 2 files changed, 22 insertions(+), 22 deletions(-)
+
+diff --git a/Support/Library/ofxsImageEffect.cpp b/Support/Library/ofxsImageEffect.cpp
+index efad2bf..84b55c3 100644
+--- a/Support/Library/ofxsImageEffect.cpp
++++ b/Support/Library/ofxsImageEffect.cpp
+@@ -3190,8 +3190,8 @@ namespace OFX {
+ {
+ OFX::Private::VersionIDKey key;
+ key.id = id;
+- key.major = majorVersion;
+- key.minor = minorVersion;
++ key.major_version = majorVersion;
++ key.minor_version = minorVersion;
+ EffectDescriptorMap::iterator it = gEffectDescriptors.find(key);
+ EffectContextMap& toBeDeleted = it->second;
+ for(EffectContextMap::iterator it2 = toBeDeleted.begin(); it2 != toBeDeleted.end(); ++it2)
+@@ -3594,8 +3594,8 @@ namespace OFX {
+ // make a roi setter object
+ OFX::Private::VersionIDKey key;
+ key.id = plugname;
+- key.major = majorVersion;
+- key.minor = minorVersion;
++ key.major_version = majorVersion;
++ key.minor_version = minorVersion;
+ ActualROISetter setRoIs(outArgs, gEffectDescriptors[key][effectInstance->getContext()]->getClipROIPropNames());
+
+ // and call the plugin client code
+@@ -3681,8 +3681,8 @@ namespace OFX {
+ // make a roi setter object
+ OFX::Private::VersionIDKey key;
+ key.id = plugname;
+- key.major = majorVersion;
+- key.minor = minorVersion;
++ key.major_version = majorVersion;
++ key.minor_version = minorVersion;
+ ActualSetter setFrames(outArgs, gEffectDescriptors[key][effectInstance->getContext()]->getClipFrameRangePropNames());
+
+ // and call the plugin client code
+@@ -3777,8 +3777,8 @@ namespace OFX {
+ // set up our clip preferences setter
+ OFX::Private::VersionIDKey key;
+ key.id = plugname;
+- key.major = majorVersion;
+- key.minor = minorVersion;
++ key.major_version = majorVersion;
++ key.minor_version = minorVersion;
+ ImageEffectDescriptor* desc = gEffectDescriptors[key][effectInstance->getContext()];
+ ClipPreferencesSetter prefs(outArgs, desc->getClipDepthPropNames(), desc->getClipComponentPropNames(), desc->getClipPARPropNames());
+
+@@ -3910,8 +3910,8 @@ namespace OFX {
+
+ OFX::Private::VersionIDKey key;
+ key.id = plugname;
+- key.major = majorVersion;
+- key.minor = minorVersion;
++ key.major_version = majorVersion;
++ key.minor_version = minorVersion;
+ ImageEffectDescriptor* desc = gEffectDescriptors[key][effectInstance->getContext()];
+ FrameViewsNeededSetter setter(outArgs,desc->getClipFrameViewsPropNames());
+ effectInstance->getFrameViewsNeeded(args,setter);
+@@ -3932,8 +3932,8 @@ namespace OFX {
+
+ OFX::Private::VersionIDKey key;
+ key.id = plugname;
+- key.major = majorVersion;
+- key.minor = minorVersion;
++ key.major_version = majorVersion;
++ key.minor_version = minorVersion;
+ ImageEffectDescriptor* desc = gEffectDescriptors[key][effectInstance->getContext()];
+ ClipComponentsSetter setter(outArgs,desc->getClipPlanesPropNames());
+ effectInstance->getClipComponents(args,setter);
+@@ -4056,8 +4056,8 @@ namespace OFX {
+ // add it to our map
+ OFX::Private::VersionIDKey key;
+ key.id = it->first;
+- key.major = it->second._plug->pluginVersionMajor;
+- key.minor = it->second._plug->pluginVersionMinor;
++ key.major_version = it->second._plug->pluginVersionMajor;
++ key.minor_version = it->second._plug->pluginVersionMinor;
+ gEffectDescriptors[key][eContextNone] = desc;
+
+ // got here, must be good
+@@ -4082,8 +4082,8 @@ namespace OFX {
+ // add it to our map
+ OFX::Private::VersionIDKey key;
+ key.id = it->first;
+- key.major = it->second._plug->pluginVersionMajor;
+- key.minor = it->second._plug->pluginVersionMinor;
++ key.major_version = it->second._plug->pluginVersionMajor;
++ key.minor_version = it->second._plug->pluginVersionMinor;
+ gEffectDescriptors[key][context] = desc;
+
+ // got here, must be good
+diff --git a/Support/Library/ofxsSupportPrivate.h b/Support/Library/ofxsSupportPrivate.h
+index 84e9af0..d1b3d5f 100644
+--- a/Support/Library/ofxsSupportPrivate.h
++++ b/Support/Library/ofxsSupportPrivate.h
+@@ -129,22 +129,22 @@ namespace OFX {
+
+ struct VersionIDKey
+ {
+- unsigned int major,minor;
++ unsigned int major_version,minor_version;
+ std::string id;
+
+- VersionIDKey(): major(0), minor(0), id() {}
++ VersionIDKey(): major_version(0), minor_version(0), id() {}
+
+ bool operator< (const VersionIDKey& rhs) const
+ {
+ if (id == rhs.id) {
+- if (major == rhs.major) {
+- if (minor == rhs.minor) {
++ if (major_version == rhs.major_version) {
++ if (minor_version == rhs.minor_version) {
+ return false;
+ } else {
+- return minor < rhs.minor;
++ return minor_version < rhs.minor_version;
+ }
+ } else {
+- return major < rhs.major;
++ return major_version < rhs.major_version;
+ }
+ } else {
+ return id < rhs.id;
+--
+2.9.3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..57da97d2de95
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Hugo Courtial <hugo [at] courtial [not colon] me>
+pkgname=openfx-arena
+pkgver=2.1.2
+pkgrel=1
+arch=("i686" "x86_64")
+pkgdesc="Extra OpenFX plugins for Natron"
+url="https://github.com/olear/openfx-arena/tree/Natron-$pkgver"
+license=("GPL2")
+depends=("gcc-libs-multilib" "imagemagick" "libcdr" "librsvg" "libtool" "libzip" "opencolorio" "poppler-glib")
+source=("$pkgname::git://github.com/olear/openfx-arena.git#tag=Natron-$pkgver" "GCC6.patch")
+md5sums=("SKIP" "8da02f30c37861eaaac9245ff4cb005b")
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ git submodule update -i --recursive
+ cd "OpenFX"
+ #note : patch is only useful for 2.1.2 & lower. should be fixed in next release
+ patch -uNp1 -i $srcdir/GCC6.patch
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ make CONFIG=release
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ mkdir -p "$pkgdir/usr/OFX/Plugins"
+ make install PLUGINPATH=$pkgdir/usr/OFX/Plugins CONFIG=release
+}