summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTércio Martins2018-11-04 17:43:50 -0200
committerTércio Martins2018-11-04 17:43:50 -0200
commitb17e567f9e367945d1b39c57dfc2949f7786d1f5 (patch)
tree861dbcea29c75e9fd0f3e2fdd0a74cfe4ae47044
parent22a3ecef7ab9b1f010e43ab3b1ffd4f8d9a89953 (diff)
downloadaur-b17e567f9e367945d1b39c57dfc2949f7786d1f5.tar.gz
PKGBUILD modified to work around a bug in the imagemagick package, as pointed out by @ es_18 in the comments.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
-rw-r--r--im7.patch10
3 files changed, 23 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c7c86c64abf6..f8d21e26e4e1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openfx-arena
pkgdesc = Extra OpenFX plugins for Natron
pkgver = 2.3.14
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/NatronGitHub/openfx-arena
arch = i686
arch = x86_64
@@ -22,12 +22,14 @@ pkgbase = openfx-arena
source = git+https://github.com/NatronGitHub/openfx-io
source = git+https://github.com/NatronGitHub/SequenceParsing
source = git+https://github.com/NatronGitHub/tinydir
+ source = im7.patch
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
+ md5sums = 2e4cf8665b074afe84d743ea86e9e89e
pkgname = openfx-arena
diff --git a/PKGBUILD b/PKGBUILD
index 2166b7670199..b460dac67e29 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,25 +4,28 @@
pkgname=openfx-arena
pkgver=2.3.14
-pkgrel=1
+pkgrel=2
arch=("i686" "x86_64")
pkgdesc="Extra OpenFX plugins for Natron"
url="https://github.com/NatronGitHub/openfx-arena"
license=("GPL")
makedepends=("git")
-depends=('libcdr' 'libgl' 'libmagick' 'librsvg' 'libxt' 'libzip' 'ocl-icd' 'opencolorio' 'poppler-glib')
+depends=('libcdr' 'libgl' 'libmagick' 'librsvg' 'libxt' 'libzip' \
+ 'ocl-icd' 'opencolorio' 'poppler-glib')
source=("$pkgname::git+https://github.com/NatronGitHub/openfx-arena#tag=Natron-$pkgver"
"git+https://github.com/NatronGitHub/openfx"
"git+https://github.com/NatronGitHub/openfx-supportext"
"git+https://github.com/NatronGitHub/openfx-io"
"git+https://github.com/NatronGitHub/SequenceParsing"
- "git+https://github.com/NatronGitHub/tinydir")
+ "git+https://github.com/NatronGitHub/tinydir"
+ "im7.patch")
md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP')
+ 'SKIP'
+ '2e4cf8665b074afe84d743ea86e9e89e')
# Check the ImageMagick version
_IM_VERSION=$(echo `identify -version` | tr -dc '0-9' | cut -c 1)
@@ -47,8 +50,10 @@ prepare() {
build() {
cd "$srcdir/$pkgname"
+ patch Makefile.master ../../im7.patch
make CONFIG=release \
- IM=$_IM_VERSION
+ IM=$_IM_VERSION \
+ #LIBS="-linotify"
}
package() {
diff --git a/im7.patch b/im7.patch
new file mode 100644
index 000000000000..5057ac6ae647
--- /dev/null
+++ b/im7.patch
@@ -0,0 +1,10 @@
+# Patch created to fix an ImageMagick bug introduced in version 7.0.8.
+# The error has already been fixed, and the fix will be made available in the next stable release.
+# Further details at the link below:
+# https://github.com/ImageMagick/ImageMagick/pull/1371
+
+10c10,11
+< MAGICK_LINKFLAGS = $(shell pkg-config Magick++ --libs --static)
+---
+> MAGICK_LINKFLAGS = $(shell pkg-config Magick++ --libs --static | sed "s/MAGICK_EXTRA_DEP_LIBS//g")
+>