summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTércio Martins2022-12-12 01:50:12 -0300
committerTércio Martins2022-12-12 01:50:12 -0300
commit62b41cf163929b7fd59adc203c97e5df74df4826 (patch)
tree0af1b3198941b9e7c5dbcab4c646ab729f6e40ff
parentaa77ecd119a7423529ebef5241598741a6249d26 (diff)
downloadaur-openfx-arena-git.tar.gz
Update the "git submodule" command with new Git security settings
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD47
2 files changed, 18 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 225016427a84..2a6cb17508f7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,20 @@
pkgbase = openfx-arena-git
pkgdesc = Extra OpenFX plugins for Natron
- pkgver = Natron.2.4.3.r6.g2e56d77
+ pkgver = Natron.2.4.4.r1.gd7c5f1b
pkgrel = 1
url = https://github.com/NatronGitHub/openfx-arena
arch = x86_64
license = GPL
makedepends = git
makedepends = jbigkit
- makedepends = opencolorio1
makedepends = openmp
makedepends = pango
depends = libcdr
- depends = libgl
depends = libmagick
depends = librsvg
depends = libxt
depends = libzip
+ depends = opencolorio
depends = poppler-glib
depends = sox
conflicts = openfx-arena
diff --git a/PKGBUILD b/PKGBUILD
index 03c6ca1b3337..1a5ba6026468 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
# Contributor: Luca Weiss <luca (at) z3ntu (dot) xyz>
pkgname=openfx-arena-git
-pkgver=Natron.2.4.3.r6.g2e56d77
+pkgver=Natron.2.4.4.r1.gd7c5f1b
pkgrel=1
arch=('x86_64')
pkgdesc="Extra OpenFX plugins for Natron"
url="https://github.com/NatronGitHub/openfx-arena"
license=('GPL')
-depends=('libcdr' 'libgl' 'libmagick' 'librsvg' 'libxt' 'libzip' 'poppler-glib' 'sox')
-makedepends=('git' 'jbigkit' 'opencolorio1' 'openmp' 'pango')
+depends=('libcdr' 'libmagick' 'librsvg' 'libxt' 'libzip' 'opencolorio' 'poppler-glib' 'sox')
+makedepends=('git' 'jbigkit' 'openmp' 'pango')
_pkgname=${pkgname%-git}
_url=${url%/${_pkgname}}
@@ -33,45 +33,30 @@ sha512sums=('SKIP'
'SKIP')
pkgver() {
- cd ${_pkgname}
+ cd $_pkgname
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd ${_pkgname}
+ cd $_pkgname
git submodule init
- git config submodule.OpenFX.url ${srcdir}/openfx
- git config submodule.OpenFX-IO.url ${srcdir}/openfx-io
- git config submodule.SupportExt.url ${srcdir}/openfx-supportext
- git config submodule.lodepng.url ${srcdir}/lodepng
- git submodule update
+ git config submodule.OpenFX.url "$srcdir"/openfx
+ git config submodule.OpenFX-IO.url "$srcdir"/openfx-io
+ git config submodule.SupportExt.url "$srcdir"/openfx-supportext
+ git config submodule.lodepng.url "$srcdir"/lodepng
+ git -c protocol.file.allow=always submodule update
cd OpenFX-IO
git submodule init
- git config submodule.openfx.url ${srcdir}/openfx
- git config submodule.SupportExt.url ${srcdir}/openfx-supportext
- git config submodule.IOSupport/SequenceParsing.url ${srcdir}/SequenceParsing
- git submodule update
+ git config submodule.openfx.url "$srcdir"/openfx
+ git config submodule.SupportExt.url "$srcdir"/openfx-supportext
+ git config submodule.IOSupport/SequenceParsing.url "$srcdir"/SequenceParsing
+ git -c protocol.file.allow=always submodule update
cd IOSupport/SequenceParsing
git submodule init
- git config submodule.tinydir.url ${srcdir}/tinydir
- git submodule update
-
- cd ../../../
-
-# Change OpenColorIO library references to the version of "opencolorio1" package
- find OpenFX-IO/IOSupport/ -name GenericOCIO.* \
- -exec sed -i 's|include <OpenColorIO/|include <OpenColorIO1/|' {} \;
-
-# Solve a problem in the linking of the "Extra" plugins,
-# caused by a misconfiguration of pkgconfig in the "libzip" package
- sed -i '/ZIP_LINKFLAGS/ s|\$.*libs.*|-lbz2 -llzma -lzstd -lgnutls -lnettle -lz|' \
- Makefile.master
-
-# The ReadPDF plugin needs Poppler, which uses C++17 features
- sed -i "/POPPLER_CXXFLAGS/ s/$/ -std=c++17/" \
- Makefile.master
+ git config submodule.tinydir.url "$srcdir"/tinydir
+ git -c protocol.file.allow=always submodule update
}
build() {