summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name2017-11-07 16:26:17 -0400
committerYour Name2017-11-07 16:26:17 -0400
commit0a29bd887cd5f318e6c0fb550a8213a6fa3212b6 (patch)
tree4e31535f946f28deddce7031694b929a8e623c93
parent7ca2cad26e058a046ef0816faf4110586f8c2146 (diff)
downloadaur-0a29bd887cd5f318e6c0fb550a8213a6fa3212b6.tar.gz
fix
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD23
2 files changed, 8 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e0c6f40465d5..01a7fdbea84d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openfx-arena-git
pkgdesc = A set of Readers/Writers plugins written using the OpenFX standard
pkgver = 2.3.3
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/MrKepzie/openfx-io
arch = i686
arch = x86_64
@@ -14,15 +14,7 @@ pkgbase = openfx-arena-git
depends = ffmpeg
optdepends = openfx-gmic-bin
optdepends = natron-plugins
- source = openfx-arena-git::git+https://github.com/MrKepzie/openfx-arena.git#commit=6c9adf4026446cb688fc9878c768cac103582603
- source = git+https://github.com/devernay/openfx.git
- source = git+https://github.com/MrKepzie/SequenceParsing
- source = git+https://github.com/devernay/openfx-supportext.git
- source = git+https://github.com/MrKepzie/tinydir
- sha512sums = SKIP
- sha512sums = SKIP
- sha512sums = SKIP
- sha512sums = SKIP
+ source = openfx-arena::git+https://github.com/MrKepzie/openfx-arena.git#commit=6c9adf4026446cb688fc9878c768cac103582603
sha512sums = SKIP
pkgname = openfx-arena-git
diff --git a/PKGBUILD b/PKGBUILD
index c65dc1f8a27b..509f285f8398 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=openfx-arena-git
name=openfx-arena
pkgver=2.3.3
-pkgrel=4
+pkgrel=5
arch=("i686" "x86_64")
pkgdesc="A set of Readers/Writers plugins written using the OpenFX standard"
url="https://github.com/MrKepzie/openfx-io"
@@ -13,29 +13,18 @@ depends=("seexpr1" "openimageio" "ffmpeg")
#depends=("opencolorio" "openexr" "openimageio" "ffmpeg" "boost-libs")
makedepends=("git" "expat" "boost")
optdepends=("openfx-gmic-bin" "natron-plugins")
-source=("$pkgname::git+https://github.com/MrKepzie/openfx-arena.git#commit=6c9adf4026446cb688fc9878c768cac103582603"
- 'git+https://github.com/devernay/openfx.git'
- 'git+https://github.com/MrKepzie/SequenceParsing'
- 'git+https://github.com/devernay/openfx-supportext.git'
- 'git+https://github.com/MrKepzie/tinydir')
+source=("openfx-arena::git+https://github.com/MrKepzie/openfx-arena.git#commit=6c9adf4026446cb688fc9878c768cac103582603"
+)
sha512sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP')
+)
_bits=32 ; [[ "$CARCH" = 'x86_64' ]] && _bits=64
prepare() {
cd "$srcdir/$name"
- git config submodule.openfx.url $srcdir/openfx
- git config submodule.IOSupport/SequenceParsing.url $srcdir/SequenceParsing
- git config submodule.SupportExt.url $srcdir/openfx-supportext
- git submodule update
- cd IOSupport/SequenceParsing
- git config submodule.tinydir.url $srcdir/tinydir
- git submodule update
+ git submodule update --init --recursive
+
}
build() {