summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTércio Martins2018-08-06 03:05:34 -0300
committerTércio Martins2018-08-06 03:05:34 -0300
commit27106634be426aebff5ca8fb80500875b54bb4a1 (patch)
tree75e24b5269e8652c73ac65eb72679b333d07c652
parentfc2022b29b11716d2a999acd1391eccc94fc6ab4 (diff)
downloadaur-27106634be426aebff5ca8fb80500875b54bb4a1.tar.gz
Upgrade to version 2.3.14
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD16
2 files changed, 15 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b5c64e0fa8e1..40f4d1a6ab85 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = openfx-gmic
pkgdesc = OpenFX wrapper for the G'MIC framework
- pkgver = 2.3.13
+ pkgver = 2.3.14
pkgrel = 1
url = https://github.com/NatronGitHub/openfx-gmic
+ arch = i686
arch = x86_64
license = custom:CeCILL-C
license = custom:CeCILLv2
@@ -14,7 +15,7 @@ pkgbase = openfx-gmic
depends = curl
depends = fftw
depends = libgl
- source = openfx-gmic::git+https://github.com/NatronGitHub/openfx-gmic#tag=Natron-2.3.13
+ source = openfx-gmic::git+https://github.com/NatronGitHub/openfx-gmic#tag=Natron-2.3.14
source = git+https://github.com/NatronGitHub/openfx
sha512sums = SKIP
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 0d116b32aa14..425b44d80076 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Tércio Martins <echo dGVyY2lvd2VuZGVsQGdtYWlsLmNvbQo= | base64 -d>
pkgname=openfx-gmic
-pkgver=2.3.13
+pkgver=2.3.14
pkgrel=1
-arch=("x86_64")
+arch=("i686" "x86_64")
pkgdesc="OpenFX wrapper for the G'MIC framework"
url="https://github.com/NatronGitHub/openfx-gmic"
license=('custom:CeCILL-C' 'custom:CeCILLv2')
@@ -14,6 +14,14 @@ source=("$pkgname::git+https://github.com/NatronGitHub/openfx-gmic#tag=Natron-$p
sha512sums=('SKIP'
'SKIP')
+# Checks whether the environment is 32-bit or 64-bit
+if [ $CARCH == 'x86_64' ]
+then
+ _BITS=64
+else
+ _BITS=32
+fi
+
prepare() {
cd "$srcdir/$pkgname"
git config submodule.openfx.url $srcdir/openfx
@@ -23,7 +31,7 @@ prepare() {
build() {
cd "$srcdir/$pkgname"
make CONFIG=release \
- BITS=64
+ BITS=$_BITS
}
package() {
@@ -31,7 +39,7 @@ package() {
install -d "$pkgdir/usr/OFX/Plugins"
make install PLUGINPATH=$pkgdir/usr/OFX/Plugins \
CONFIG=release \
- BITS=64
+ BITS=$_BITS
mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
install -Dm644 $srcdir/$pkgname/COPYING "$pkgdir/usr/share/licenses/$pkgname/"