summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTércio Martins2018-07-05 15:44:10 -0300
committerTércio Martins2018-07-05 15:44:10 -0300
commitfc2022b29b11716d2a999acd1391eccc94fc6ab4 (patch)
tree45d624e2b4e6a584d787153febdfb7f6f393dfe2
downloadaur-fc2022b29b11716d2a999acd1391eccc94fc6ab4.tar.gz
PKGBUILD for version 2.3.13
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD40
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b5c64e0fa8e1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = openfx-gmic
+ pkgdesc = OpenFX wrapper for the G'MIC framework
+ pkgver = 2.3.13
+ pkgrel = 1
+ url = https://github.com/NatronGitHub/openfx-gmic
+ arch = x86_64
+ license = custom:CeCILL-C
+ license = custom:CeCILLv2
+ makedepends = gimp
+ makedepends = git
+ makedepends = opencv
+ makedepends = openexr
+ makedepends = qt5-base
+ depends = curl
+ depends = fftw
+ depends = libgl
+ source = openfx-gmic::git+https://github.com/NatronGitHub/openfx-gmic#tag=Natron-2.3.13
+ source = git+https://github.com/NatronGitHub/openfx
+ sha512sums = SKIP
+ sha512sums = SKIP
+
+pkgname = openfx-gmic
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0d116b32aa14
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Tércio Martins <echo dGVyY2lvd2VuZGVsQGdtYWlsLmNvbQo= | base64 -d>
+
+pkgname=openfx-gmic
+pkgver=2.3.13
+pkgrel=1
+arch=("x86_64")
+pkgdesc="OpenFX wrapper for the G'MIC framework"
+url="https://github.com/NatronGitHub/openfx-gmic"
+license=('custom:CeCILL-C' 'custom:CeCILLv2')
+depends=("curl" "fftw" "libgl")
+makedepends=("gimp" "git" "opencv" "openexr" "qt5-base")
+source=("$pkgname::git+https://github.com/NatronGitHub/openfx-gmic#tag=Natron-$pkgver"
+ 'git+https://github.com/NatronGitHub/openfx')
+sha512sums=('SKIP'
+ 'SKIP')
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ git config submodule.openfx.url $srcdir/openfx
+ git submodule update
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ make CONFIG=release \
+ BITS=64
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -d "$pkgdir/usr/OFX/Plugins"
+ make install PLUGINPATH=$pkgdir/usr/OFX/Plugins \
+ CONFIG=release \
+ BITS=64
+
+ mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
+ install -Dm644 $srcdir/$pkgname/COPYING "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 $srcdir/$pkgname/Licence_CeCILL-C_V1-en.txt "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 $srcdir/$pkgname/Licence_CeCILL_V2-en.txt "$pkgdir/usr/share/licenses/$pkgname/"
+}