summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTércio Martins2021-04-24 18:12:32 -0300
committerTércio Martins2021-04-24 18:12:32 -0300
commit544f4febd333ebf3fc716b7adb0d5359f4fb9412 (patch)
tree499012a03d34392c2deaf5c90c2e7852b170e8bf
parent6feac47ddf620da92225472e590661c78619e9f5 (diff)
downloadaur-544f4febd333ebf3fc716b7adb0d5359f4fb9412.tar.gz
PKGBUILD updated according to package "openfx-gmic" version 2.4.0
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD62
2 files changed, 49 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 836f4d9e6c0c..e0862d92be83 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = openfx-gmic-git
- pkgdesc = A set of Readers/Writers plugins written using the OpenFX standard
- pkgver = 3.0.0.4
+ pkgdesc = OpenFX wrapper for the G'MIC framework
+ pkgver = Natron.2.4.0.r0.g626699d
pkgrel = 1
- url = https://github.com/MrKepzie/openfx-io
+ url = https://github.com/NatronGitHub/openfx-gmic
arch = x86_64
- license = GPL2
- makedepends = git
- makedepends = expat
- makedepends = boost
- depends = seexpr
- depends = openimageio
- depends = ffmpeg
- optdepends = openfx-gmic-bin
- optdepends = natron-plugins
- source = openfx-gmic::git+https://github.com/NatronGitHub/openfx-gmic.git#commit=1cb9ced110f2c2ba28a92477d887620566572eca
+ license = custom:CeCILL-C
+ license = custom:CeCILLv2
+ makedepends = openmp
+ depends = fftw
+ depends = libgl
+ depends = libpng
+ conflicts = openfx-gmic
+ source = openfx-gmic::git+https://github.com/NatronGitHub/openfx-gmic
+ source = openfx::git+https://github.com/NatronGitHub/openfx
+ sha512sums = SKIP
sha512sums = SKIP
pkgname = openfx-gmic-git
diff --git a/PKGBUILD b/PKGBUILD
index 6a8e798f1593..6ecdc1dfd8b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,50 @@
-# Maintainer: Hugo Courtial <hugo [at] courtial [not colon] me>
-# Maintainer: Luca Weiss <luca (at) z3ntu (dot) xyz>
+# Maintainer: Tércio Martins <echo dGVyY2lvd2VuZGVsQGdtYWlsLmNvbQo= | base64 -d>
pkgname=openfx-gmic-git
-name=openfx-gmic
-pkgver=3.0.0.4
+pkgver=Natron.2.4.0.r0.g626699d
pkgrel=1
-arch=("x86_64")
-pkgdesc="A set of Readers/Writers plugins written using the OpenFX standard"
-url="https://github.com/MrKepzie/openfx-io"
-license=("GPL2")
-depends=("seexpr" "openimageio" "ffmpeg")
-#depends=("opencolorio" "openexr" "openimageio" "ffmpeg" "boost-libs")
-makedepends=("git" "expat" "boost")
-optdepends=("openfx-gmic-bin" "natron-plugins")
-com=1cb9ced110f2c2ba28a92477d887620566572eca
-source=("$name::git+https://github.com/NatronGitHub/openfx-gmic.git#commit=$com"
-)
-sha512sums=('SKIP'
-)
+arch=('x86_64')
+pkgdesc="OpenFX wrapper for the G'MIC framework"
+url="https://github.com/NatronGitHub/openfx-gmic"
+license=('custom:CeCILL-C' 'custom:CeCILLv2')
+depends=('fftw' 'libgl' 'libpng')
+makedepends=('openmp')
-_bits=32 ; [[ "$CARCH" = 'x86_64' ]] && _bits=64
+_pkgname=${pkgname%-git}
+_url=${url%/${_pkgname}}
-prepare() {
- cd "$srcdir/$name"
+conflicts=("${_pkgname}")
- git submodule update --init --recursive
+source=("${_pkgname}::git+${url}"
+ "openfx::git+${_url}/openfx")
+sha512sums=('SKIP'
+ 'SKIP')
+prepare() {
+ cd ${_pkgname}
+ git submodule init
+ git config submodule.openfx.url ${srcdir}/openfx
+ git submodule update
}
build() {
- cd "$srcdir/$name"
- make -j10 CONFIG=release
+ cd ${_pkgname}
+ make CONFIG=release \
+ OPENMP=1
}
package() {
- cd "$srcdir/$name"
- mkdir -p "$pkgdir/usr/OFX/Plugins"
- make install PLUGINPATH=$pkgdir/usr/OFX/Plugins CONFIG=release BITS=$_bits
+ cd ${_pkgname}
+ install -d "${pkgdir}/usr/OFX/Plugins"
+ make install PLUGINPATH="${pkgdir}/usr/OFX/Plugins" \
+ CONFIG=release
+
+ mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
+
+ install -Dm644 COPYING \
+ "${pkgdir}/usr/share/licenses/${pkgname}/"
+ install -Dm644 Licence_CeCILL-C_V1-en.txt \
+ "${pkgdir}/usr/share/licenses/${pkgname}/"
+ install -Dm644 Licence_CeCILL_V2-en.txt \
+ "${pkgdir}/usr/share/licenses/${pkgname}/"
}