summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTércio Martins2021-04-24 18:13:55 -0300
committerTércio Martins2021-04-24 18:13:55 -0300
commit17d97c5fec2faaf7ba8204c4b01e9a540a54eb87 (patch)
treef3ebb2ce7b75d6b859ee06e8ba04cde5aab150bd
parenta37dce35b2ab8c2ed7b64844236b6132c9a99ec2 (diff)
downloadaur-17d97c5fec2faaf7ba8204c4b01e9a540a54eb87.tar.gz
PKGBUILD updated according to package "openfx-io" version 2.4.0
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD67
2 files changed, 58 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a06fcdcf6bfc..dbe5a6443bda 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,23 @@
pkgbase = openfx-io-git
pkgdesc = A set of Readers/Writers plugins written using the OpenFX standard
- pkgver = 2.3.11
- pkgrel = 3
- url = https://github.com/MrKepzie/openfx-io
+ pkgver = Natron.2.4.0.r0.g47c236e
+ pkgrel = 1
+ url = https://github.com/NatronGitHub/openfx-io
arch = x86_64
- license = GPL2
- makedepends = git
- makedepends = expat
- makedepends = boost
- depends = seexpr
- depends = openimageio
+ license = GPL
depends = ffmpeg
- optdepends = openfx-gmic-bin
- optdepends = natron-plugins
- source = openfx-io::git+https://github.com/NatronGitHub/openfx-io.git#commit=c1936718d3f42bc455f9e25341e1fa027152e0c8
+ depends = openimageio
+ depends = libseexpr2
+ conflicts = openfx-io
+ source = openfx-io::git+https://github.com/NatronGitHub/openfx-io
+ source = openfx::git+https://github.com/NatronGitHub/openfx
+ source = openfx-supportext::git+https://github.com/NatronGitHub/openfx-supportext
+ source = SequenceParsing::git+https://github.com/NatronGitHub/SequenceParsing
+ source = tinydir::git+https://github.com/NatronGitHub/tinydir
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
sha512sums = SKIP
pkgname = openfx-io-git
diff --git a/PKGBUILD b/PKGBUILD
index cf8f7e0c4b6f..982d6af44b26 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,55 @@
-# Maintainer: Hugo Courtial <hugo [at] courtial [not colon] me>
-# Maintainer: Luca Weiss <luca (at) z3ntu (dot) xyz>
+# Maintainer: Tércio Martins <echo dGVyY2lvd2VuZGVsQGdtYWlsLmNvbQo= | base64 -d>
+# Contributor: Hugo Courtial <hugo [at] courtial [not colon] me>
+# Contributor: Luca Weiss <luca (at) z3ntu (dot) xyz>
pkgname=openfx-io-git
-name=openfx-io
-pkgver=2.3.11
-pkgrel=3
-arch=("x86_64")
+pkgver=Natron.2.4.0.r0.g47c236e
+_pkgname="${pkgname}-Natron-${pkgver}"
+pkgrel=1
+arch=('x86_64')
pkgdesc="A set of Readers/Writers plugins written using the OpenFX standard"
-url="https://github.com/MrKepzie/openfx-io"
-license=("GPL2")
-depends=("seexpr" "openimageio" "ffmpeg")
-#depends=("opencolorio" "openexr" "openimageio" "ffmpeg" "boost-libs")
-makedepends=("git" "expat" "boost")
-optdepends=("openfx-gmic-bin" "natron-plugins")
-com=c1936718d3f42bc455f9e25341e1fa027152e0c8
-source=("openfx-io::git+https://github.com/NatronGitHub/openfx-io.git#commit=$com"
-)
-sha512sums=('SKIP'
-)
+url="https://github.com/NatronGitHub/openfx-io"
+license=('GPL')
+depends=('ffmpeg' 'openimageio' 'libseexpr2')
+
+_pkgname=${pkgname%-git}
+_url=${url%/${_pkgname}}
-_bits=32 ; [[ "$CARCH" = 'x86_64' ]] && _bits=64
+conflicts=("${_pkgname}")
+
+source=("${_pkgname}::git+${url}"
+ "openfx::git+${_url}/openfx"
+ "openfx-supportext::git+${_url}/openfx-supportext"
+ "SequenceParsing::git+${_url}/SequenceParsing"
+ "tinydir::git+${_url}/tinydir")
+sha512sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
prepare() {
- cd "$srcdir/$name"
- git submodule update --init --recursive
+ cd ${_pkgname}
+ git submodule init
+ git config submodule.openfx.url ${srcdir}/openfx
+ git config submodule.SupportExt.url ${srcdir}/openfx-supportext
+ git config submodule.IOSupport/SequenceParsing.url ${srcdir}/SequenceParsing
+ git submodule update
+
+ cd IOSupport/SequenceParsing
+ git submodule init
+ git config submodule.tinydir.url ${srcdir}/tinydir
+ git submodule update
}
build() {
- cd "$srcdir/$name"
- make CONFIG=release BITS=$_bits
+ cd "${srcdir}/${_pkgname}"
+ make CONFIG=release
}
package() {
- cd "$srcdir/$name"
- mkdir -p "$pkgdir/usr/OFX/Plugins"
- make install PLUGINPATH=$pkgdir/usr/OFX/Plugins CONFIG=release BITS=$_bits
+ cd "${srcdir}/${_pkgname}"
+ mkdir -p "${pkgdir}/usr/OFX/Plugins"
+ make install PLUGINPATH="${pkgdir}/usr/OFX/Plugins" \
+ CONFIG=release
}