summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTércio Martins2018-08-06 03:07:38 -0300
committerTércio Martins2018-08-06 03:07:38 -0300
commit5bdf2206a1464e87e310bed6bf8b32a08966dbec (patch)
treee10e6de19bb443707dbcb75cd831a187e3fbaad1
parenta8a28f1f25b765a7cf67d2fbdc09a60bc73e707a (diff)
downloadaur-5bdf2206a1464e87e310bed6bf8b32a08966dbec.tar.gz
Upgrade to version 2.3.14
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD20
2 files changed, 19 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e55e6908442e..a2def8195dbe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = openfx-misc
pkgdesc = Miscellaneous OpenFX plugins
- pkgver = 2.3.13
+ pkgver = 2.3.14
pkgrel = 1
url = https://github.com/NatronGitHub/openfx-misc
+ arch = i686
arch = x86_64
license = GPL
makedepends = git
+ makedepends = openmp
depends = libgl
optdepends = natron-plugins
- source = openfx-misc::git+https://github.com/NatronGitHub/openfx-misc#tag=Natron-2.3.13
+ source = openfx-misc::git+https://github.com/NatronGitHub/openfx-misc#tag=Natron-2.3.14
source = git+https://github.com/NatronGitHub/openfx
source = git+https://github.com/NatronGitHub/openfx-supportext
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index b7e1e1f3b89e..0979a0b80afa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
# Contributor: Luca Weiss <luca (at) z3ntu (dot) xyz>
pkgname=openfx-misc
-pkgver=2.3.13
+pkgver=2.3.14
pkgrel=1
-arch=("x86_64")
+arch=("i686" "x86_64")
pkgdesc="Miscellaneous OpenFX plugins"
url="https://github.com/NatronGitHub/openfx-misc"
license=("GPL")
-makedepends=("git")
+makedepends=("git" "openmp")
depends=("libgl")
optdepends=("natron-plugins")
source=("$pkgname::git+https://github.com/NatronGitHub/openfx-misc#tag=Natron-$pkgver"
@@ -19,6 +19,14 @@ sha512sums=('SKIP'
'SKIP'
'SKIP')
+# Checks whether the environment is 32-bit or 64-bit
+if [ $CARCH == 'x86_64' ]
+then
+ _BITS=64
+else
+ _BITS=32
+fi
+
prepare() {
cd "$srcdir/$pkgname"
git config submodule.openfx.url $srcdir/openfx
@@ -29,7 +37,9 @@ prepare() {
build() {
cd "$srcdir/$pkgname"
make CONFIG=release \
- BITS=64
+ CXXFLAGS_ADD=-fopenmp \
+ LDFLAGS_ADD=-fopenmp \
+ BITS=$_BITS
}
package() {
@@ -37,5 +47,5 @@ package() {
mkdir -p "$pkgdir/usr/OFX/Plugins"
make install PLUGINPATH=$pkgdir/usr/OFX/Plugins \
CONFIG=release \
- BITS=64
+ BITS=$_BITS
}