summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTércio Martins2018-06-19 02:06:34 -0300
committerTércio Martins2018-06-19 02:06:34 -0300
commit8023570f252fbe2e316126d36fe26b9028b7285c (patch)
tree420403486d765a8475dbd7a1512dbca3e550b317
parent6b395564a14b76ed255c7fa14f11b2ea3493e607 (diff)
downloadaur-8023570f252fbe2e316126d36fe26b9028b7285c.tar.gz
Upgrade to version 2.3.12
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 21 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a8dff4529131..f721d09f7e8c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,19 @@
pkgbase = openfx-misc
pkgdesc = Miscellaneous OpenFX plugins
- pkgver = 2.3.4
+ pkgver = 2.3.12
pkgrel = 1
- url = https://github.com/devernay/openfx-misc
+ url = https://github.com/NatronGitHub/openfx-misc
arch = x86_64
- license = GPL2
+ license = GPL
makedepends = git
depends = libgl
- optdepends = openfx-gmic-bin
optdepends = natron-plugins
- source = openfx-misc::git+https://github.com/devernay/openfx-misc.git#tag=Natron-2.3.4
- source = git+https://github.com/devernay/openfx.git
- source = git+https://github.com/devernay/openfx-supportext.git
+ source = openfx-misc::git+https://github.com/NatronGitHub/openfx-misc#tag=Natron-2.3.12
+ source = git+https://github.com/NatronGitHub/openfx
+ source = git+https://github.com/NatronGitHub/openfx-supportext
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
- depends_x86_64 = gcc-libs-multilib
pkgname = openfx-misc
diff --git a/PKGBUILD b/PKGBUILD
index c000bd58c29a..e9b5d17e2c26 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,24 @@
-# Maintainer: Hugo Courtial <hugo [at] courtial [not colon] me>
-# Maintainer: Luca Weiss <luca (at) z3ntu (dot) xyz>
+# Maintainer: Tércio Martins <echo dGVyY2lvd2VuZGVsQGdtYWlsLmNvbQo= | base64 -d>
+# Contributor: Hugo Courtial <hugo [at] courtial [not colon] me>
+# Contributor: Luca Weiss <luca (at) z3ntu (dot) xyz>
pkgname=openfx-misc
-pkgver=2.3.4
+pkgver=2.3.12
pkgrel=1
arch=("x86_64")
pkgdesc="Miscellaneous OpenFX plugins"
-url="https://github.com/devernay/openfx-misc"
-license=("GPL2")
+url="https://github.com/NatronGitHub/openfx-misc"
+license=("GPL")
makedepends=("git")
depends=("libgl")
-depends_x86_64=("gcc-libs-multilib")
-optdepends=("openfx-gmic-bin" "natron-plugins")
-source=("$pkgname::git+https://github.com/devernay/openfx-misc.git#tag=Natron-$pkgver"
- "git+https://github.com/devernay/openfx.git"
- "git+https://github.com/devernay/openfx-supportext.git")
+optdepends=("natron-plugins")
+source=("$pkgname::git+https://github.com/NatronGitHub/openfx-misc#tag=Natron-$pkgver"
+ "git+https://github.com/NatronGitHub/openfx"
+ "git+https://github.com/NatronGitHub/openfx-supportext")
sha512sums=('SKIP'
'SKIP'
'SKIP')
-_bits=32 ; [[ "$CARCH" = 'x86_64' ]] && _bits=64
-
prepare() {
cd "$srcdir/$pkgname"
git config submodule.openfx.url $srcdir/openfx
@@ -30,11 +28,14 @@ prepare() {
build() {
cd "$srcdir/$pkgname"
- make CONFIG=release BITS=$_bits
+ make CONFIG=release \
+ BITS=64
}
package() {
cd "$srcdir/$pkgname"
mkdir -p "$pkgdir/usr/OFX/Plugins"
- make install PLUGINPATH=$pkgdir/usr/OFX/Plugins CONFIG=release BITS=$_bits
+ make install PLUGINPATH=$pkgdir/usr/OFX/Plugins \
+ CONFIG=release \
+ BITS=64
}