summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuca Weiss2016-11-20 21:58:56 +0100
committerLuca Weiss2016-11-20 21:58:56 +0100
commit8381cb29ac5170e3d1ded43d4ce55c82b16154a2 (patch)
tree6b09dc5bfd91d13a4becf0135e3e2ccac3d4e519
parent5cf617c3908cd4dd7bf2607b1b1eb4ed2f0762e0 (diff)
downloadaur-8381cb29ac5170e3d1ded43d4ce55c82b16154a2.tar.gz
Update to 2.1.8
-rw-r--r--.SRCINFO14
-rw-r--r--GCC6.patch138
-rw-r--r--PKGBUILD31
3 files changed, 27 insertions, 156 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c9dcf6dd2c77..0b99e9d1a256 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,22 @@
+# Generated by mksrcinfo v8
+# Sun Nov 20 20:52:44 UTC 2016
pkgbase = openfx-misc
pkgdesc = Miscellaneous OpenFX plugins
- pkgver = 2.1.2
+ pkgver = 2.1.8
pkgrel = 1
- url = https://github.com/devernay/openfx-misc/tree/Natron-2.1.2
+ url = https://github.com/devernay/openfx-misc/tree/Natron-2.1.8
arch = i686
arch = x86_64
license = GPL2
makedepends = git
depends = libgl
depends = gcc-libs-multilib
- source = openfx-misc::git://github.com/devernay/openfx-misc.git#tag=Natron-2.1.2
- source = GCC6.patch
+ source = openfx-misc::git://github.com/devernay/openfx-misc.git#tag=Natron-2.1.8
+ source = git+https://github.com/devernay/openfx.git
+ source = git+https://github.com/devernay/openfx-supportext.git
+ md5sums = SKIP
+ md5sums = SKIP
md5sums = SKIP
- md5sums = 8da02f30c37861eaaac9245ff4cb005b
pkgname = openfx-misc
diff --git a/GCC6.patch b/GCC6.patch
deleted file mode 100644
index f7046197a6f1..000000000000
--- a/GCC6.patch
+++ /dev/null
@@ -1,138 +0,0 @@
-From 48241ff38192fd1310ec7ab6ac9179e0269ab1de Mon Sep 17 00:00:00 2001
-From: Hugo Courtial <hugo@courtial.me>
-Date: Sat, 20 Aug 2016 23:12:38 +0200
-Subject: [PATCH] GCC6 patches
-
----
- Support/Library/ofxsImageEffect.cpp | 32 ++++++++++++++++----------------
- Support/Library/ofxsSupportPrivate.h | 12 ++++++------
- 2 files changed, 22 insertions(+), 22 deletions(-)
-
-diff --git a/Support/Library/ofxsImageEffect.cpp b/Support/Library/ofxsImageEffect.cpp
-index efad2bf..84b55c3 100644
---- a/Support/Library/ofxsImageEffect.cpp
-+++ b/Support/Library/ofxsImageEffect.cpp
-@@ -3190,8 +3190,8 @@ namespace OFX {
- {
- OFX::Private::VersionIDKey key;
- key.id = id;
-- key.major = majorVersion;
-- key.minor = minorVersion;
-+ key.major_version = majorVersion;
-+ key.minor_version = minorVersion;
- EffectDescriptorMap::iterator it = gEffectDescriptors.find(key);
- EffectContextMap& toBeDeleted = it->second;
- for(EffectContextMap::iterator it2 = toBeDeleted.begin(); it2 != toBeDeleted.end(); ++it2)
-@@ -3594,8 +3594,8 @@ namespace OFX {
- // make a roi setter object
- OFX::Private::VersionIDKey key;
- key.id = plugname;
-- key.major = majorVersion;
-- key.minor = minorVersion;
-+ key.major_version = majorVersion;
-+ key.minor_version = minorVersion;
- ActualROISetter setRoIs(outArgs, gEffectDescriptors[key][effectInstance->getContext()]->getClipROIPropNames());
-
- // and call the plugin client code
-@@ -3681,8 +3681,8 @@ namespace OFX {
- // make a roi setter object
- OFX::Private::VersionIDKey key;
- key.id = plugname;
-- key.major = majorVersion;
-- key.minor = minorVersion;
-+ key.major_version = majorVersion;
-+ key.minor_version = minorVersion;
- ActualSetter setFrames(outArgs, gEffectDescriptors[key][effectInstance->getContext()]->getClipFrameRangePropNames());
-
- // and call the plugin client code
-@@ -3777,8 +3777,8 @@ namespace OFX {
- // set up our clip preferences setter
- OFX::Private::VersionIDKey key;
- key.id = plugname;
-- key.major = majorVersion;
-- key.minor = minorVersion;
-+ key.major_version = majorVersion;
-+ key.minor_version = minorVersion;
- ImageEffectDescriptor* desc = gEffectDescriptors[key][effectInstance->getContext()];
- ClipPreferencesSetter prefs(outArgs, desc->getClipDepthPropNames(), desc->getClipComponentPropNames(), desc->getClipPARPropNames());
-
-@@ -3910,8 +3910,8 @@ namespace OFX {
-
- OFX::Private::VersionIDKey key;
- key.id = plugname;
-- key.major = majorVersion;
-- key.minor = minorVersion;
-+ key.major_version = majorVersion;
-+ key.minor_version = minorVersion;
- ImageEffectDescriptor* desc = gEffectDescriptors[key][effectInstance->getContext()];
- FrameViewsNeededSetter setter(outArgs,desc->getClipFrameViewsPropNames());
- effectInstance->getFrameViewsNeeded(args,setter);
-@@ -3932,8 +3932,8 @@ namespace OFX {
-
- OFX::Private::VersionIDKey key;
- key.id = plugname;
-- key.major = majorVersion;
-- key.minor = minorVersion;
-+ key.major_version = majorVersion;
-+ key.minor_version = minorVersion;
- ImageEffectDescriptor* desc = gEffectDescriptors[key][effectInstance->getContext()];
- ClipComponentsSetter setter(outArgs,desc->getClipPlanesPropNames());
- effectInstance->getClipComponents(args,setter);
-@@ -4056,8 +4056,8 @@ namespace OFX {
- // add it to our map
- OFX::Private::VersionIDKey key;
- key.id = it->first;
-- key.major = it->second._plug->pluginVersionMajor;
-- key.minor = it->second._plug->pluginVersionMinor;
-+ key.major_version = it->second._plug->pluginVersionMajor;
-+ key.minor_version = it->second._plug->pluginVersionMinor;
- gEffectDescriptors[key][eContextNone] = desc;
-
- // got here, must be good
-@@ -4082,8 +4082,8 @@ namespace OFX {
- // add it to our map
- OFX::Private::VersionIDKey key;
- key.id = it->first;
-- key.major = it->second._plug->pluginVersionMajor;
-- key.minor = it->second._plug->pluginVersionMinor;
-+ key.major_version = it->second._plug->pluginVersionMajor;
-+ key.minor_version = it->second._plug->pluginVersionMinor;
- gEffectDescriptors[key][context] = desc;
-
- // got here, must be good
-diff --git a/Support/Library/ofxsSupportPrivate.h b/Support/Library/ofxsSupportPrivate.h
-index 84e9af0..d1b3d5f 100644
---- a/Support/Library/ofxsSupportPrivate.h
-+++ b/Support/Library/ofxsSupportPrivate.h
-@@ -129,22 +129,22 @@ namespace OFX {
-
- struct VersionIDKey
- {
-- unsigned int major,minor;
-+ unsigned int major_version,minor_version;
- std::string id;
-
-- VersionIDKey(): major(0), minor(0), id() {}
-+ VersionIDKey(): major_version(0), minor_version(0), id() {}
-
- bool operator< (const VersionIDKey& rhs) const
- {
- if (id == rhs.id) {
-- if (major == rhs.major) {
-- if (minor == rhs.minor) {
-+ if (major_version == rhs.major_version) {
-+ if (minor_version == rhs.minor_version) {
- return false;
- } else {
-- return minor < rhs.minor;
-+ return minor_version < rhs.minor_version;
- }
- } else {
-- return major < rhs.major;
-+ return major_version < rhs.major_version;
- }
- } else {
- return id < rhs.id;
---
-2.9.3
-
diff --git a/PKGBUILD b/PKGBUILD
index b42ad59f2fb5..64d623552f2e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,8 @@
# Maintainer: Hugo Courtial <hugo [at] courtial [not colon] me>
+# Maintainer: Luca Weiss <luca (at) z3ntu (dot) xyz>
+
pkgname=openfx-misc
-pkgver=2.1.2
+pkgver=2.1.8
pkgrel=1
arch=("i686" "x86_64")
pkgdesc="Miscellaneous OpenFX plugins"
@@ -8,25 +10,28 @@ url="https://github.com/devernay/openfx-misc/tree/Natron-$pkgver"
license=("GPL2")
makedepends=("git")
depends=("libgl" "gcc-libs-multilib")
-source=("$pkgname::git://github.com/devernay/openfx-misc.git#tag=Natron-$pkgver" "GCC6.patch")
-md5sums=("SKIP" "8da02f30c37861eaaac9245ff4cb005b")
+source=("$pkgname::git://github.com/devernay/openfx-misc.git#tag=Natron-$pkgver"
+ "git+https://github.com/devernay/openfx.git"
+ "git+https://github.com/devernay/openfx-supportext.git")
+md5sums=("SKIP"
+ "SKIP"
+ "SKIP")
_bits=32 ; [[ "$CARCH" = 'x86_64' ]] && _bits=64
prepare() {
- cd "$srcdir/$pkgname"
- git submodule update -i --recursive
- cd "openfx"
- #note : patch is only useful for 2.1.2 & lower. should be fixed in next release
- patch -uNp1 -i $srcdir/GCC6.patch
+ cd "$srcdir/$pkgname"
+ git config submodule.openfx.url $srcdir/openfx
+ git config submodule.SupportExt.url $srcdir/openfx-supportext
+ git submodule update
}
build() {
- cd "$srcdir/$pkgname"
- make CONFIG=release BITS=$_bits
+ cd "$srcdir/$pkgname"
+ make CONFIG=release BITS=$_bits
}
package() {
- cd "$srcdir/$pkgname"
- mkdir -p "$pkgdir/usr/OFX/Plugins"
- make install PLUGINPATH=$pkgdir/usr/OFX/Plugins CONFIG=release BITS=$_bits
+ cd "$srcdir/$pkgname"
+ mkdir -p "$pkgdir/usr/OFX/Plugins"
+ make install PLUGINPATH=$pkgdir/usr/OFX/Plugins CONFIG=release BITS=$_bits
}