summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name2017-11-07 16:21:15 -0400
committerYour Name2017-11-07 16:21:15 -0400
commitf9154c35dedcb28e2f5700b6052b83242b3cf5d3 (patch)
tree847a5867afcb47be05839cec8f4f9ec1247f76e1
parent61873847e9694f25e48b8eb5c2347ad543e48eb9 (diff)
downloadaur-f9154c35dedcb28e2f5700b6052b83242b3cf5d3.tar.gz
g
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD23
2 files changed, 6 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 21f127a55d09..7211bccd3ff4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openfx-misc-git
pkgdesc = A set of Readers/Writers plugins written using the OpenFX standard
pkgver = 2.3.3
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/MrKepzie/openfx-io
arch = i686
arch = x86_64
@@ -15,14 +15,6 @@ pkgbase = openfx-misc-git
optdepends = openfx-gmic-bin
optdepends = natron-plugins
source = openfx-misc-git::git+https://github.com/MrKepzie/openfx-misc.git#commit=5b01ce1fff57fb0af801031ff9c0d3d3f2b85beb
- source = git+https://github.com/devernay/openfx.git
- source = git+https://github.com/MrKepzie/SequenceParsing
- source = git+https://github.com/devernay/openfx-supportext.git
- source = git+https://github.com/MrKepzie/tinydir
- sha512sums = SKIP
- sha512sums = SKIP
- sha512sums = SKIP
- sha512sums = SKIP
sha512sums = SKIP
pkgname = openfx-misc-git
diff --git a/PKGBUILD b/PKGBUILD
index cf4eef06056e..52263378e944 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=openfx-misc-git
pkgver=2.3.3
-pkgrel=3
+pkgrel=4
arch=("i686" "x86_64")
pkgdesc="A set of Readers/Writers plugins written using the OpenFX standard"
url="https://github.com/MrKepzie/openfx-io"
@@ -13,28 +13,15 @@ depends=("seexpr1" "openimageio" "ffmpeg")
makedepends=("git" "expat" "boost")
optdepends=("openfx-gmic-bin" "natron-plugins")
source=("$pkgname::git+https://github.com/MrKepzie/openfx-misc.git#commit=5b01ce1fff57fb0af801031ff9c0d3d3f2b85beb"
- 'git+https://github.com/devernay/openfx.git'
- 'git+https://github.com/MrKepzie/SequenceParsing'
- 'git+https://github.com/devernay/openfx-supportext.git'
- 'git+https://github.com/MrKepzie/tinydir')
+)
sha512sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP')
+)
_bits=32 ; [[ "$CARCH" = 'x86_64' ]] && _bits=64
prepare() {
cd "$srcdir/$pkgname"
- git config submodule.openfx.url $srcdir/openfx
- git config submodule.IOSupport/SequenceParsing.url $srcdir/SequenceParsing
- git config submodule.SupportExt.url $srcdir/openfx-supportext
- git submodule update
-
- cd IOSupport/SequenceParsing
- git config submodule.tinydir.url $srcdir/tinydir
- git submodule update
+ git submodule update --init --recursive
}
build() {
@@ -46,4 +33,4 @@ package() {
cd "$srcdir/$pkgname"
mkdir -p "$pkgdir/usr/OFX/Plugins"
make install PLUGINPATH=$pkgdir/usr/OFX/Plugins CONFIG=release BITS=$_bits
-} \ No newline at end of file
+}