summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcyrozap2018-12-08 17:10:48 -0600
committercyrozap2018-12-08 17:12:49 -0600
commit39da52c515d280e8b6e3b9b271c44bd8541945d0 (patch)
tree0c72a071ee54e19ebd9739d267f1d8952fe645d9
parent36d4191125fd48d75e82a0532ec1f6ce8b313406 (diff)
downloadaur-39da52c515d280e8b6e3b9b271c44bd8541945d0.tar.gz
Updated to latest version
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
2 files changed, 11 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d0b7781f91eb..120398c4e3c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = opengv-git
pkgdesc = An efficient C++ library for calibrated camera pose computation using geometric computer vision algorithms.
- pkgver = r91.0b2017d
- pkgrel = 2
+ pkgver = r144.306a54e
+ pkgrel = 1
url = https://laurentkneip.github.io/opengv/
arch = i686
arch = x86_64
@@ -15,9 +15,7 @@ pkgbase = opengv-git
provides = opengv
conflicts = opengv
source = opengv::git+https://github.com/laurentkneip/opengv.git
- source = https://github.com/laurentkneip/opengv/pull/61.patch
- source = https://github.com/laurentkneip/opengv/pull/76.patch
- sha256sums = SKIP
+ source = git+https://github.com/pybind/pybind11.git
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index ea11b70e5861..59eed8415df2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Forest Crossman <cyrozap at gmail dot com>
pkgname=opengv-git
-pkgver=r91.0b2017d
-pkgrel=2
+pkgver=r144.306a54e
+pkgrel=1
pkgdesc="An efficient C++ library for calibrated camera pose computation using geometric computer vision algorithms."
arch=('i686' 'x86_64')
url="https://laurentkneip.github.io/opengv/"
@@ -12,12 +12,9 @@ makedepends=('boost' 'cmake' 'git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=("${pkgname%-git}::git+https://github.com/laurentkneip/opengv.git"
- "https://github.com/laurentkneip/opengv/pull/61.patch"
- "https://github.com/laurentkneip/opengv/pull/76.patch")
+ "git+https://github.com/pybind/pybind11.git")
sha256sums=('SKIP'
- 'SKIP'
- 'SKIP')
-
+ 'SKIP')
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -27,16 +24,15 @@ pkgver() {
prepare() {
cd "$srcdir/${pkgname%-git}"
- patch -p1 < ../61.patch
- patch -p1 < ../76.patch
-
- [ ! -d build ] || rm -r build
+ git submodule init
+ git config submodule.pybind11.url ${srcdir}/pybind11
+ git submodule update
}
build() {
cd "$srcdir/${pkgname%-git}"
- mkdir build
+ mkdir -p build
cd build
cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \