summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcyrozap2018-07-28 13:01:47 -0500
committercyrozap2018-07-28 13:02:36 -0500
commit71e3866643af8fe837952df40b31d878c7792b62 (patch)
tree3ebdf87d2641230a951a9723212a7dbb4102cbeb
parent2d602259e7534a022aacae66651d893a81105d58 (diff)
downloadaur-71e3866643af8fe837952df40b31d878c7792b62.tar.gz
Fix build for newer versions of boost
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d113eba5420..b1a4277d377d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = opengv-git
pkgdesc = An efficient C++ library for calibrated camera pose computation using geometric computer vision algorithms.
- pkgver = r85.02697d3
+ pkgver = r91.0b2017d
pkgrel = 1
url = https://laurentkneip.github.io/opengv/
arch = i686
@@ -15,7 +15,9 @@ pkgbase = opengv-git
provides = opengv
conflicts = opengv
source = opengv::git+https://github.com/laurentkneip/opengv.git
- md5sums = SKIP
+ source = https://github.com/laurentkneip/opengv/pull/61.patch
+ sha256sums = SKIP
+ sha256sums = 75b2c4bffc77590a992c76079da32daa653096f144583a8296ed384dfda3006d
pkgname = opengv-git
diff --git a/PKGBUILD b/PKGBUILD
index 1790444af77c..9ae78e496d37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Forest Crossman <cyrozap at gmail dot com>
pkgname=opengv-git
-pkgver=r85.02697d3
+pkgver=r91.0b2017d
pkgrel=1
pkgdesc="An efficient C++ library for calibrated camera pose computation using geometric computer vision algorithms."
arch=('i686' 'x86_64')
@@ -11,8 +11,10 @@ depends=('boost-libs' 'eigen>=3' 'python2')
makedepends=('boost' 'cmake' 'git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=("${pkgname%-git}::git+https://github.com/laurentkneip/opengv.git")
-md5sums=('SKIP')
+source=("${pkgname%-git}::git+https://github.com/laurentkneip/opengv.git"
+ "https://github.com/laurentkneip/opengv/pull/61.patch")
+sha256sums=('SKIP'
+ '75b2c4bffc77590a992c76079da32daa653096f144583a8296ed384dfda3006d')
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -23,6 +25,8 @@ pkgver() {
prepare() {
cd "$srcdir/${pkgname%-git}"
+ patch -p1 < ../61.patch
+
[ ! -d build ] || rm -r build
}