summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThorsten Lanfer2015-06-30 23:36:26 +0200
committerThorsten Lanfer2015-06-30 23:36:26 +0200
commit40e9bca75e837059eeaaef1618e79570a4c65df1 (patch)
tree1746e86cfd7cfc9cffc11f8c1d213ee0917fae4e
downloadaur-40e9bca75e837059eeaaef1618e79570a4c65df1.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c7790167ceef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = openhab-addons
+ pkgdesc = openHAB automation addons
+ pkgver = 1.7.0
+ pkgrel = 1
+ url = http://www.openhab.org/
+ arch = any
+ license = EPL
+ makedepends = unzip
+ depends = java-runtime>=7
+ depends = openhab-runtime=1.7.0
+ noextract = distribution-1.7.0-addons.zip
+ source = https://bintray.com/artifact/download/openhab/bin/distribution-1.7.0-addons.zip
+ md5sums = e2340abbb14fc6c22e0d884a431dc5de
+
+pkgname = openhab-addons
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1428101fd742
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Thorsten Lanfer <tlanfer@gmail.com>
+pkgname=openhab-addons
+pkgver=1.7.0
+pkgrel=1
+pkgdesc="openHAB automation addons"
+arch=('any')
+url="http://www.openhab.org/"
+license=('EPL')
+depends=('java-runtime>=7'
+ 'openhab-runtime=1.7.0')
+makedepends=('unzip')
+optdepends=()
+backup=()
+source=("https://bintray.com/artifact/download/openhab/bin/distribution-$pkgver-addons.zip")
+noextract=("distribution-$pkgver-addons.zip")
+md5sums=('e2340abbb14fc6c22e0d884a431dc5de')
+
+prepare() {
+ mkdir "$srcdir/$pkgname"
+ cd "$srcdir/$pkgname"
+
+ unzip "$srcdir/distribution-$pkgver-addons.zip"
+
+}
+
+package() {
+ cd $pkgdir
+ mkdir -p opt
+ cp -r $srcdir/openhab-addons opt
+}