summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcodeworkx2016-03-26 08:08:11 +0100
committercodeworkx2016-03-26 08:08:11 +0100
commit58c80a124132be7836dd5984a94af0989e9b70e7 (patch)
treea7b0edd832d67b898052b30b93c5a5993103b024
parent267ad00739d34b5ecbf545be6787848ff229b157 (diff)
downloadaur-58c80a124132be7836dd5984a94af0989e9b70e7.tar.gz
fix package version
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 303104210dca..0f67b924da03 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,7 +9,7 @@ pkgbase = openhab-beta
depends = java-runtime-headless>=8
conflicts = openhab-runtime
conflicts = openhab-addons
- noextract = openhab-online-2.0.0_20160326-SNAPSHOT.zip
+ noextract = openhab-online-2.0.0-SNAPSHOT.zip
backup = etc/openhab/conf/addons.cfg
backup = etc/openhab/conf/runtime.cfg
source = https://openhab.ci.cloudbees.com/job/openHAB-Distribution/lastSuccessfulBuild/artifact/distributions/openhab-online/target/openhab-online-2.0.0-SNAPSHOT.zip
diff --git a/PKGBUILD b/PKGBUILD
index 3dab52ba9971..fdb14d61ddb7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
# Maintainer: Daniel Hillenbrand <codeworkx@bbqlinux.org>
pkgname=openhab-beta
+_pkgver=2.0.0
pkgver=2.0.0_20160326
pkgrel=1
pkgdesc="openHAB2 open source home automation software"
@@ -14,23 +15,23 @@ conflicts=('openhab-runtime' 'openhab-addons')
backup=('etc/openhab/conf/addons.cfg'
'etc/openhab/conf/runtime.cfg')
-source=("https://openhab.ci.cloudbees.com/job/openHAB-Distribution/lastSuccessfulBuild/artifact/distributions/openhab-online/target/openhab-online-2.0.0-SNAPSHOT.zip"
+source=("https://openhab.ci.cloudbees.com/job/openHAB-Distribution/lastSuccessfulBuild/artifact/distributions/openhab-online/target/openhab-online-${_pkgver}-SNAPSHOT.zip"
"openhab.service")
-noextract=("openhab-online-$pkgver-SNAPSHOT.zip")
+noextract=("openhab-online-${_pkgver}-SNAPSHOT.zip")
sha1sums=('SKIP'
'3494cf262f5b87dcff75044c8c2eee670a6f715c')
pkgver() {
- printf "2.0.0_%s" "$(date +%Y%m%d)"
+ printf "${_pkgver}_%s" "$(date +%Y%m%d)"
}
prepare() {
mkdir -p "$srcdir/openhab"
cd "$srcdir/openhab"
- unzip "$srcdir/openhab-online-$pkgver-SNAPSHOT.zip"
+ unzip "$srcdir/openhab-online-${_pkgver}-SNAPSHOT.zip"
}