summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcodeworkx2018-03-02 19:21:41 +0100
committercodeworkx2018-03-02 19:21:41 +0100
commitbc9da3ad09be0e94519348b77e6b90681f208d7a (patch)
tree0527be681644c29e5bbc6a6c059e91613080a3c1
parent485a5018dea9ace1fa6198321a55c53b3cb1b2ac (diff)
downloadaur-bc9da3ad09be0e94519348b77e6b90681f208d7a.tar.gz
fix startup issue
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
-rw-r--r--openhab.service6
3 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b0e8216bf86..4d8f9ae05bc2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,13 +9,14 @@ pkgbase = openhab-beta
depends = java-runtime-headless>=8
conflicts = openhab-runtime
conflicts = openhab-addons
+ conflicts = openhab2
noextract = openhab-2.3.0-SNAPSHOT.zip
backup = etc/openhab/conf/services/addons.cfg
backup = etc/openhab/conf/services/runtime.cfg
source = https://openhab.ci.cloudbees.com/job/openHAB-Distribution/lastSuccessfulBuild/artifact/distributions/openhab/target/openhab-2.3.0-SNAPSHOT.zip
source = openhab.service
sha256sums = SKIP
- sha256sums = 92be5e206c878bb1a1b476f62b815f24dca198e8e0055095f797d264d8521bfe
+ sha256sums = 79b57f9f6b6e832f1bc60649990c147825a36e76858c43d3f1464f6b98530bdb
pkgname = openhab-beta
diff --git a/PKGBUILD b/PKGBUILD
index aa7f9029e381..2028f4bdde10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ license=('EPL')
depends=('java-runtime-headless>=8')
makedepends=('unzip')
-conflicts=('openhab-runtime' 'openhab-addons')
+conflicts=('openhab-runtime' 'openhab-addons' 'openhab2')
backup=('etc/openhab/conf/services/addons.cfg'
'etc/openhab/conf/services/runtime.cfg')
@@ -21,7 +21,7 @@ source=("https://openhab.ci.cloudbees.com/job/openHAB-Distribution/lastSuccessfu
noextract=("openhab-${_pkgver}-SNAPSHOT.zip")
sha256sums=('SKIP'
- '92be5e206c878bb1a1b476f62b815f24dca198e8e0055095f797d264d8521bfe')
+ '79b57f9f6b6e832f1bc60649990c147825a36e76858c43d3f1464f6b98530bdb')
pkgver() {
printf "${_pkgver}_%s" "$(date +%Y%m%d)"
diff --git a/openhab.service b/openhab.service
index bd3c54c99dd5..95fc3b4c0e90 100644
--- a/openhab.service
+++ b/openhab.service
@@ -1,11 +1,13 @@
[Unit]
Description=OpenHAB home automation software
-After=syslog.target network.target
+Wants=network-online.target
+After=network-online.target
[Service]
Type=simple
-ExecStart=/opt/openhab/start.sh
+ExecStart=/opt/openhab/start.sh server
ExecReload=/usr/bin/kill -HUP $MAINPID
+Restart=on-failure
[Install]
WantedBy=multi-user.target